From e5bee3ff2bb78215951a000d67ed662013986201 Mon Sep 17 00:00:00 2001
From: Matthew T Hoare <matthew.t.hoare@gmail.com>
Date: Sat, 13 Jun 2020 04:21:02 +0000
Subject: [PATCH] testing/azote: new aport

---
 testing/azote/APKBUILD | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
 create mode 100644 testing/azote/APKBUILD

diff --git a/testing/azote/APKBUILD b/testing/azote/APKBUILD
new file mode 100644
index 000000000000..e3bff4c48a24
--- /dev/null
+++ b/testing/azote/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Matthew T Hoare <matthew.t.hoare@gmail.com>
+# Maintainer: Matthew T Hoare <matthew.t.hoare@gmail.com>
+pkgname=azote
+pkgver=1.7.11
+pkgrel=0
+pkgdesc="Wallpaper and colour manager for Sway, i3 and other window managers"
+url="https://github.com/nwg-piotr/azote"
+arch="noarch"
+license="GPL-3.0-or-later AND BSD-3-Clause"
+depends="python3 py3-setuptools py3-gobject3 py3-pillow py3-send2trash feh xrandr"
+makedepends="python3"
+options="!check" # no checks
+source="$pkgname-$pkgver.tar.gz::https://github.com/nwg-piotr/azote/archive/v$pkgver.tar.gz"
+
+package() {
+	install -Dm755 dist/azote "$pkgdir"/usr/bin/azote
+	install -D -t "$pkgdir"/usr/share/"$pkgname" dist/azote.svg
+	install -D -t "$pkgdir"/usr/share/"$pkgname" dist/indicator_active.png
+	install -D -t "$pkgdir"/usr/share/"$pkgname" dist/indicator_attention.png
+	install -D -t "$pkgdir"/usr/share/applications dist/azote.desktop
+	python3 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+sha512sums="6fe249db2dc17c3b7824b58e1d5455583a2f743ca742452a98aeced56c833f05f44e43254396f594ca6b0acc0f3690014f986f483e622019ccf5e45ed221d3b0  azote-1.7.11.tar.gz"
-- 
GitLab