From e3e0dbb4f1fb93bf80e76bb0e25663496bfb858e Mon Sep 17 00:00:00 2001
From: Bart Ribbers <bribbers@disroot.org>
Date: Mon, 16 May 2022 09:20:04 +0200
Subject: [PATCH] community/qt5-qtlocation: upgrade to 5.15.4_git20220511

---
 community/qt5-qtlocation/APKBUILD        | 47 +++++++++++++-----------
 community/qt5-qtlocation/fix-build.patch | 13 -------
 2 files changed, 26 insertions(+), 34 deletions(-)
 delete mode 100644 community/qt5-qtlocation/fix-build.patch

diff --git a/community/qt5-qtlocation/APKBUILD b/community/qt5-qtlocation/APKBUILD
index 18dda21b89f3..8911e1daacd8 100644
--- a/community/qt5-qtlocation/APKBUILD
+++ b/community/qt5-qtlocation/APKBUILD
@@ -1,38 +1,41 @@
 # Contributor: Francesco Colista <fcolista@alpinelinux.org>
 # Maintainer: Bart Ribbers <bribbers@disroot.org>
 pkgname=qt5-qtlocation
-pkgver=5.15.3_git20201109
-pkgrel=3
-_commit="861e372b6ad81570d4f496e42fb25a6699b72f2f"
+pkgver=5.15.4_git20220511
+pkgrel=0
+_commit="db3b6bc6afed6477e6ab2d8465e41efee30fb6d5"
+_commit_mapbox="d3101bbc22edd41c9036ea487d4a71eabd97823d"
 pkgdesc="Qt5 - Location component"
 url="https://www.qt.io/developers/"
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
 license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
-makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev icu-dev"
+arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+makedepends="
+	qt5-qtbase-dev
+	qt5-qtdeclarative-dev
+	icu-dev
+	"
 subpackages="$pkgname-dev"
 options="!check" # No tests
-builddir="$srcdir/qtlocation"
+builddir="$srcdir/qtlocation-$_commit"
 
 case $pkgver in
 	*_beta*|*_rc*) _rel=development_releases;;
 	*) _rel=official_releases;;
 esac
 
-source="https://dev.alpinelinux.org/archive/qt5-qtlocation/qtlocation-$_commit.tar.gz
-	fix-build.patch
+source="https://invent.kde.org/qt/qt/qtlocation/-/archive/$_commit/qtlocation-$_commit.tar.gz
+	https://invent.kde.org/qt/qt/qtlocation-mapboxgl/-/archive/$_commit_mapbox/qtlocation-mapbox-$_commit_mapbox.tar.gz
 	"
 
-disturl="dev.alpinelinux.org:/archive/$pkgname/"
-
-snapshot() {
-	clean
-	deps
-	mkdir -p "$srcdir"
-	cd "$srcdir"
-	git clone https://invent.kde.org/qt/qt/qtlocation -b kde/5.15 --recursive
-	cd qtlocation && git checkout $_commit && cd -
-	tar czvf $SRCDEST/qtlocation-$_commit.tar.gz qtlocation
-	rsync --progress -La $SRCDEST/qtlocation-$_commit.tar.gz $disturl
+prepare() {
+	default_prepare
+
+	rmdir src/3rdparty/mapbox-gl-native
+	mv "$srcdir/qtlocation-mapboxgl-$_commit_mapbox" src/3rdparty/mapbox-gl-native
+
+    # We need to make the build system think we're running in a git repository
+    # so it correctly symlinks during the build
+	mkdir .git
 }
 
 build() {
@@ -50,5 +53,7 @@ package() {
 	install -d "$pkgdir"/usr/share/licenses
 	ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
 }
-sha512sums="5e9feabbac29052377d2cd1ec22fa29b00de361122580f0f33128fadf12b72af711f2e1e114a3e82c7c00812b304287212d617c85fe1b5bb0f39f120c884d8cc  qtlocation-861e372b6ad81570d4f496e42fb25a6699b72f2f.tar.gz
-eb19b97909b64a82d75732872573b25c626c924aec93dbbe9b1b27fd72354149aa0c4e2d3727a5a2519a7bee39cb6af60761ad40e29b4e7adeb89a300a710505  fix-build.patch"
+sha512sums="
+36a4133edcb9f2cdeb75603c966aba3e5b9b6e071f00b24ab8920257471246fbe0c9cb73b41b4b2c6716a1d60d7bd12423694fdef53139b7f1e033fb677a8f60  qtlocation-db3b6bc6afed6477e6ab2d8465e41efee30fb6d5.tar.gz
+6e38e5ca0b9e17de690af79f4702278bdc933a74561aa135b3e82245df7d795602403048bcc5bce00237f774ce3957540a8bded1a71f8730a08da05dec1f039f  qtlocation-mapbox-d3101bbc22edd41c9036ea487d4a71eabd97823d.tar.gz
+"
diff --git a/community/qt5-qtlocation/fix-build.patch b/community/qt5-qtlocation/fix-build.patch
deleted file mode 100644
index 65131f47392f..000000000000
--- a/community/qt5-qtlocation/fix-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/3rdparty/mapbox-gl-native/mapbox-gl-native.pro b/src/3rdparty/mapbox-gl-native/mapbox-gl-native.pro
-index ed974db..265fe96 100644
---- a/src/3rdparty/mapbox-gl-native/mapbox-gl-native.pro
-+++ b/src/3rdparty/mapbox-gl-native/mapbox-gl-native.pro
-@@ -21,7 +21,7 @@ QMAKE_CXXFLAGS += \
-     -fvisibility-inlines-hidden \
-     -fvisibility=hidden
- 
--android|win32|darwin|qnx {
-+android|win32|darwin|qnx|posix {
-     SOURCES += \
-         platform/qt/src/thread.cpp
- } else {
-- 
GitLab