diff --git a/testing/yyjson/APKBUILD b/testing/yyjson/APKBUILD
index e55afd8da69d52cf9cd73618f3a4aa75f31c6074..73e2841a3766d61b42c2dec374d317cccc2c4caf 100644
--- a/testing/yyjson/APKBUILD
+++ b/testing/yyjson/APKBUILD
@@ -11,6 +11,7 @@ makedepends="cmake samurai"
 subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
 source="https://github.com/ibireme/yyjson/archive/$pkgver/yyjson-$pkgver.tar.gz
 	false-error-about-uninitialized-variable.patch
+	no-werror.patch
 	"
 
 build() {
@@ -41,4 +42,5 @@ package() {
 sha512sums="
 91a14d2292cebc5d3eb0954511c1d27d6fa45f778febe73bac700acdbeba3bfc485db444d49cab903dc323eacdb74625059465e4a45a1eca5a1e397768f422f5  yyjson-0.7.0.tar.gz
 7ba5d285e8c357a56ba8f6db3721aaea55bc180420075d8475e5a13692c547fe151c879ca2d37e7ac61a09059aa46d62083a69c2b0e5c320f2cd704303750a7d  false-error-about-uninitialized-variable.patch
+72eae771d738e82ca7703453b6f21097f178cdbdb4bff67da617ac5503e27d8b34578c2f99300559f2dbfcc212b53f171956ff21aa072abbdb9d0acb73f02386  no-werror.patch
 "
diff --git a/testing/yyjson/no-werror.patch b/testing/yyjson/no-werror.patch
new file mode 100644
index 0000000000000000000000000000000000000000..b0e95f5c9664d620e8adc5411310837f44045377
--- /dev/null
+++ b/testing/yyjson/no-werror.patch
@@ -0,0 +1,12 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 165d83e..9410941 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -325,7 +325,6 @@ if(YYJSON_BUILD_TESTS)
+         set(YYJSON_BASE_FLAGS
+             -pedantic
+             -pedantic-errors
+-            -Werror
+             -Wall
+             -Wextra
+             -Wconversion