Commit e1e5de92 authored by Leo's avatar Leo Committed by Francesco Colista
Browse files

community/ffmpeg: modernize

parent c8272ff8
......@@ -12,14 +12,13 @@ license="LGPL-2.1-or-later GPL-2.0-or-later"
options="!check" # tests/data/hls-lists.append.m3u8 fails
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
makedepends="gnutls-dev lame-dev libvorbis-dev xvidcore-dev zlib-dev libvdpau-dev
imlib2-dev x264-dev libtheora-dev coreutils bzip2-dev perl-dev libvpx-dev
imlib2-dev x264-dev libtheora-dev coreutils bzip2-dev perl-dev
libvpx-dev sdl2-dev libxfixes-dev libva-dev alsa-lib-dev
v4l-utils-dev yasm opus-dev x265-dev libass-dev"
checkdepends="rsync"
source="https://ffmpeg.org/releases/ffmpeg-$pkgver.tar.xz
0001-libavutil-clean-up-unused-FF_SYMVER-macro.patch
"
builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
# 4.0.2-r0:
......@@ -71,7 +70,6 @@ build() {
x86 | arm*) _asm="--disable-asm" ;;
esac
cd "$builddir"
./configure \
--prefix=/usr \
--enable-avresample \
......@@ -106,7 +104,6 @@ build() {
# https://ffmpeg.org/fate.html
check() {
cd "$builddir"
./configure \
--samples=fate-suite/
make fate-rsync
......@@ -115,7 +112,6 @@ check() {
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install install-man
install -D -m755 tools/qt-faststart "$pkgdir/usr/bin/qt-faststart"
# strip --strip-debug "$pkgdir"/usr/lib/*.a
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment