From e16913b9d2c1df8de616884ff3e162befbfdeaf6 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Tue, 23 May 2023 19:43:19 +0000
Subject: [PATCH] main/busybox: fix cross thing again

the conditional is wrong, i.e. it was 'fixes' to run on cross only, not when !cross as intended
oops
---
 main/busybox/APKBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 251c69a4c906..1374bda83d4d 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -274,7 +274,7 @@ EOF
 	# Install a list of symlinks installed by busybox.  This is useful for
 	# building and analyzing Alpine-based images which contain busybox, where
 	# you don't want to run busybox --list-path at analysis or build time.
-	if [ "$CHOST" != "$CBUILD" ]; then
+	if [ "$CHOST" = "$CBUILD" ]; then
 		mkdir -p "$pkgdir"/etc/busybox-paths.d
 		"$pkgdir"/bin/busybox --list-path > "$pkgdir"/etc/busybox-paths.d/busybox
 	fi
@@ -288,7 +288,7 @@ extras() {
 	# Install a list of symlinks installed by busybox-extras.  This is useful for
 	# building and analyzing Alpine-based images which contain busybox, where
 	# you don't want to run busybox --list-path at analysis or build time.
-	if [ "$CHOST" != "$CBUILD" ]; then
+	if [ "$CHOST" = "$CBUILD" ]; then
 		mkdir -p "$subpkgdir"/etc/busybox-paths.d
 		"$subpkgdir"/bin/busybox-extras --list-path > "$subpkgdir"/etc/busybox-paths.d/busybox-extras
 	fi
-- 
GitLab