diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 251c69a4c90628a2e13169300355a068c0d1835a..1374bda83d4d08fd5d5d2cebf6b7e55929167d84 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -274,7 +274,7 @@ EOF
 	# Install a list of symlinks installed by busybox.  This is useful for
 	# building and analyzing Alpine-based images which contain busybox, where
 	# you don't want to run busybox --list-path at analysis or build time.
-	if [ "$CHOST" != "$CBUILD" ]; then
+	if [ "$CHOST" = "$CBUILD" ]; then
 		mkdir -p "$pkgdir"/etc/busybox-paths.d
 		"$pkgdir"/bin/busybox --list-path > "$pkgdir"/etc/busybox-paths.d/busybox
 	fi
@@ -288,7 +288,7 @@ extras() {
 	# Install a list of symlinks installed by busybox-extras.  This is useful for
 	# building and analyzing Alpine-based images which contain busybox, where
 	# you don't want to run busybox --list-path at analysis or build time.
-	if [ "$CHOST" != "$CBUILD" ]; then
+	if [ "$CHOST" = "$CBUILD" ]; then
 		mkdir -p "$subpkgdir"/etc/busybox-paths.d
 		"$subpkgdir"/bin/busybox-extras --list-path > "$subpkgdir"/etc/busybox-paths.d/busybox-extras
 	fi