diff --git a/unmaintained/ocaml-camlp5/APKBUILD b/unmaintained/ocaml-camlp5/APKBUILD
index ae47af555cf1ea3ae27b3aca437ba5db15abb693..8a0bce3d26e2ad7b020a25f4d5722f56dd8f68ea 100644
--- a/unmaintained/ocaml-camlp5/APKBUILD
+++ b/unmaintained/ocaml-camlp5/APKBUILD
@@ -2,22 +2,21 @@
 # Maintainer: alpine-mips-patches <info@mobile-stream.com>
 pkgname=ocaml-camlp5
 _pkgname=camlp5
-pkgver=7.07
-_pkgver="rel707"
-pkgrel=1
+pkgver=8.00.01
+_pkgver="rel$pkgver"
+pkgrel=0
 pkgdesc="Preprocessor-pretty-printer of OCaml"
 url="https://camlp5.github.io"
-arch="" # "Sorry: the compatibility with ocaml version "4.08.1" is not yet implemented"
+arch="all !riscv64" # restricted by ocaml
 license="BSD-3-Clause"
 depends="ocaml-runtime"
-makedepends="ocaml ocaml-compiler-libs"
+makedepends="ocaml ocaml-compiler-libs perl"
 options="!check"
 subpackages="$pkgname-dev $pkgname-doc"
 source="$pkgname-$_pkgver.tar.gz::https://github.com/camlp5/$_pkgname/archive/$_pkgver.tar.gz"
 builddir="$srcdir/$_pkgname-$_pkgver"
 
 build() {
-	cd "$builddir"
 	./configure \
 		--prefix /usr \
 		--bindir /usr/bin \
@@ -27,7 +26,6 @@ build() {
 }
 
 package() {
-	cd "$builddir"
 	make DESTDIR="$pkgdir" install
 }
 
@@ -47,4 +45,6 @@ dev() {
 	done
 }
 
-sha512sums="e396c109c67383ba56f3ada43f5b5ece8b2339528553802386a1d9637a151a14d7dfc48c0a4219b24ca53fad7acfddfd4dc2c1fe109ced8b71f16202b94b8cf6  ocaml-camlp5-rel707.tar.gz"
+sha512sums="
+f40e57845ac4a14cf260ddd9df616d12df09f67efaf6735e915598aee981721e8203bf9203fb83d08e34e43021c08003de64dbf3bdcd4d12fd079542fb7649aa  ocaml-camlp5-rel8.00.01.tar.gz
+"