diff --git a/testing/tiptop/APKBUILD b/testing/tiptop/APKBUILD
index 707aafaaf7e574d3d11fbe0e9d09749d3f24e566..6481716b0021bf5b0cf3384b67fffc1fc94713bb 100644
--- a/testing/tiptop/APKBUILD
+++ b/testing/tiptop/APKBUILD
@@ -3,7 +3,7 @@ pkgname=tiptop
 pkgver=2.3.1
 pkgrel=0
 pkgdesc="Tiptop: Hardware Performance Counters for the Masses"
-url="http://tiptop.gforge.inria.fr"
+url="https://gitlab.inria.fr/rohou/tiptop"
 # Note: This tool requires two things to work:
 # 1: hardware counters in the cpu itself
 # 2: support in the kernel perf framework to use them
@@ -15,7 +15,7 @@ arch="x86 x86_64"
 license="GPL-2.0"
 makedepends="byacc flex linux-headers ncurses-dev libxml2-dev"
 subpackages="$pkgname-doc"
-source="http://tiptop.gforge.inria.fr/releases/tiptop-$pkgver.tar.gz"
+source="https://files.inria.fr/pacap/tiptop/tiptop-$pkgver.tar.gz"
 # Note, arg parsing appears to happen after attempting a perf syscall
 # so while it would be nice to run tiptop -h to validate the compile worked
 # there is a chance it might error out for no reason than the system building
@@ -30,4 +30,6 @@ build() {
 package() {
 	make install DESTDIR="$pkgdir"
 }
-sha512sums="73d275bc3957583524c872b401cf4fa773de7b4e7b7177f1787851f43e7c4aeefd953eb50b2dbce3babfc7a1c46707370ba4ad06998260177994b2eafb91395b  tiptop-2.3.1.tar.gz"
+sha512sums="
+73d275bc3957583524c872b401cf4fa773de7b4e7b7177f1787851f43e7c4aeefd953eb50b2dbce3babfc7a1c46707370ba4ad06998260177994b2eafb91395b  tiptop-2.3.1.tar.gz
+"