diff --git a/main/perl-posix-strftime-compiler/APKBUILD b/main/perl-posix-strftime-compiler/APKBUILD
index 1cb3fd54ff64113d139bf198ca4a3dfe6d334454..5173b7617da8b8da3b5628da0d9460b2432c9ae9 100644
--- a/main/perl-posix-strftime-compiler/APKBUILD
+++ b/main/perl-posix-strftime-compiler/APKBUILD
@@ -4,17 +4,17 @@
 pkgname=perl-posix-strftime-compiler
 #_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
 _pkgreal=POSIX-strftime-Compiler
-pkgver=0.42
-pkgrel=3
+pkgver=0.44
+pkgrel=0
 pkgdesc="GNU C library compatible strftime for loggers and servers"
 url="https://metacpan.org/release/POSIX-strftime-Compiler/"
 arch="noarch"
 license="GPL-1.0-or-later OR Artistic-1.0-Perl"
 depends="perl tzdata"
 makedepends="perl-dev perl-module-build perl-module-build-tiny"
-checkdepends="tzdata"
 subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/K/KA/KAZEBURO/POSIX-strftime-Compiler-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/K/KA/KAZEBURO/POSIX-strftime-Compiler-$pkgver.tar.gz
+	change-timezone-name.patch"
 builddir="$srcdir/$_pkgreal-$pkgver"
 
 build() {
@@ -32,4 +32,5 @@ package() {
 	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
 }
 
-sha512sums="0c07f1b8589b067533c65a023dd634a29640cb8992aae8047aa1063affe6b30b95930479829982a30a13b87bc7c9ebf82ca4837726bd29658d85d718164e3c76  POSIX-strftime-Compiler-0.42.tar.gz"
+sha512sums="34852966a46f55a65e4ee90af3aec6478456d3a7fc8f8b8e8fc4e704a8361f46abfad5fe0f356eb3432fb2e232e65004818b19f298293cc0172d576cfe34c3e1  POSIX-strftime-Compiler-0.44.tar.gz
+372ca8d3b8dfe35cbb6f67023341e59d6bca558d6a8bf8f02e79fb1f44c8d42a7c798b82e3e8732ebe7a46588912f6a533018bd4256419cd32a1257f11f5b467  change-timezone-name.patch"
diff --git a/main/perl-posix-strftime-compiler/change-timezone-name.patch b/main/perl-posix-strftime-compiler/change-timezone-name.patch
new file mode 100644
index 0000000000000000000000000000000000000000..5ef5598b3c980269957c422654c51cfcf82f186b
--- /dev/null
+++ b/main/perl-posix-strftime-compiler/change-timezone-name.patch
@@ -0,0 +1,12 @@
+diff -ru a/t/02_timezone.t b/t/02_timezone.t
+--- a/t/02_timezone.t	2021-04-03 11:56:22.696118176 -0300
++++ b/t/02_timezone.t	2021-04-03 11:57:25.279713829 -0300
+@@ -8,7 +8,7 @@
+ my $inc = join ' ', map { "-I\"$_\"" } @INC;
+ my $dir = dirname(__FILE__);
+ 
+-$ENV{TEST_TZ} = 'CET-1CEST';
++$ENV{TEST_TZ} = 'Europe/Brussels';
+ 
+ eval {
+     my $d = `"$^X" $inc $dir/02_timezone.pl %z 0 0 0 1 7 112`;