diff --git a/testing/ocaml-extlib/APKBUILD b/testing/ocaml-extlib/APKBUILD
index c940509b441b873746f1cffb5f8b781b5a1857ad..2c268e4bc7e76912679fef1f08e76f64884c0afb 100644
--- a/testing/ocaml-extlib/APKBUILD
+++ b/testing/ocaml-extlib/APKBUILD
@@ -2,16 +2,21 @@
 # Maintainer: Fernando Casas Schossow <casasfernando@outlook.com>
 pkgname=ocaml-extlib
 pkgver=1.7.8
-pkgrel=0
+pkgrel=1
 pkgdesc="OCaml ExtLib additions to the standard library"
 url="https://github.com/ygrek/ocaml-extlib"
-arch="aarch64 ppc64le x86_64" # restricted by ocaml
+arch="all !mips64 !riscv64" # limited by ocaml
 license="LGPL-2.1-or-later-WITH-linking-exception"
 makedepends="ocaml ocaml-findlib-dev ocaml-ocamldoc ocaml-cppo gawk"
 subpackages="$pkgname-dev $pkgname-doc"
 source="https://github.com/ygrek/ocaml-extlib/releases/download/$pkgver/extlib-$pkgver.tar.gz"
 builddir="$srcdir/extlib-$pkgver"
 
+# 32bit archs
+case "$CARCH" in
+    arm*|x86) options="$options textrels" ;;
+esac
+
 build() {
 	cd "$builddir"
 	make build