diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index 66c0151770a50318d9be2c40c1ae40f80ce77c26..e762c502e5287ae1feaeb86e450c9fdf021f9e50 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -9,7 +9,6 @@ url="https://git.kernel.org/cgit/utils/util-linux/util-linux.git"
 arch="all"
 license="GPL-3.0-or-later AND GPL-2.0-or-later AND GPL-2.0-only AND
 	LGPL-2.1-or-later AND BSD-3-Clause AND BSD-4-Clause-UC AND Public-Domain"
-checkdepends="bash findutils xz"
 makedepends_build="
 	autoconf
 	automake
@@ -50,6 +49,7 @@ subpackages="
 	wipefs:_mv_bin
 	"
 if [ -z "$BOOTSTRAP" ]; then
+	checkdepends="bash findutils xz procps coreutils"
 	makedepends_build="$makedepends_build asciidoctor"
 	makedepends_host="$makedepends_host
 		linux-pam-dev
@@ -64,9 +64,9 @@ if [ -z "$BOOTSTRAP" ]; then
 		runuser:_mv_bin
 		py3-libmount:_py3
 		"
-	options="!check"
 	_bootstrap_config="--enable-runuser --with-python=3 --with-econf"
 else
+	options="!check"
 	_bootstrap_config="--without-python --without-econf --disable-asciidoc --disable-login"
 fi
 subpackages="$subpackages $pkgname-doc $pkgname-misc"