diff --git a/testing/piler/APKBUILD b/testing/piler/APKBUILD
index 62e53de52477ddf169c0f1313cdfd3ab16d86f9d..9b56ef7b04d135233cca10f8a9337bcc24619095 100644
--- a/testing/piler/APKBUILD
+++ b/testing/piler/APKBUILD
@@ -1,19 +1,21 @@
 # Contributor: Noel Kuntze <noel.kuntze@thermi.consulting>
 # Maintainer: Noel Kuntze <noel.kuntze@thermi.consulting>
 pkgname=piler
-pkgver=1.4.6
+pkgver=1.4.7
 pkgrel=0
 pkgdesc="Open source email archiving solution with all the necessary features for your enterprise"
 url="https://www.mailpiler.org/"
 arch="x86_64 aarch64" # libmanticore-columnar is only supported on x86_64 and aarch64
 license="GPL-3.0-only"
+_php=php83
 depends="
 	bash
 	catdoc
 	coreutils
 	findutils
-	libmanticore-columnar
+	libcurl
 	libzip
+	libmanticore-columnar
 	manticore
 	memcached
 	poppler-utils
@@ -29,7 +31,7 @@ depends="
 #           catdoc: for reading attachments
 #           tnef: for reading attachments
 # bash is required to execute the cron maintenance scripts
-makedepends="$depends mariadb-dev php82-dev openssl-dev tre-dev libzip-dev"
+makedepends="$depends curl-dev mariadb-dev $_php-dev openssl-dev tre-dev libzip-dev"
 install="$pkgname.pre-install"
 options="!check"
 subpackages="$pkgname-openrc"
@@ -37,7 +39,7 @@ pkgusers="piler"
 pkggroups="piler"
 source="https://github.com/jsuto/piler/archive/refs/tags/piler-$pkgver.tar.gz
 	0001-manticore-conf.patch
-	
+
 	piler.initd
 	piler-smtp.initd
 	searchd.initd
@@ -54,7 +56,6 @@ build() {
 		--sbindir=/usr/bin \
 		--localstatedir=/var \
 		--libexecdir=/usr/lib \
-		--with-database=mysql \
 		--with-piler-user=root \
 		--enable-memcached
 
@@ -77,6 +78,9 @@ package() {
 	# crontab
 	install -Dm600 "$pkgdir"/usr/share/piler/piler.cron "$pkgdir"/etc/crontabs/piler
 
+	# php-fpm fix
+	sed -i "s@/run/php/php.*-fpm.sock@/run/php-fpm${_php#php}/piler.sock@" contrib/webserver/piler-nginx.conf
+
 	# configuration
 	install -Dm655 "$builddir"/contrib/webserver/piler-nginx.conf "$pkgdir"/etc/piler/piler-nginx.conf
 	install -Dm644 "$builddir"/etc/example.conf "$pkgdir"/etc/piler/piler.conf
@@ -103,7 +107,7 @@ package() {
 }
 
 sha512sums="
-be3189977608e71174d14201059210b4cdaad1bf30ec209605e68414f8be10e1aa700783d771419f8d58736d7862a1215ff2ceb44ad781a293c7b5fe0c1c8242  piler-1.4.6.tar.gz
+0794b3d7e88a164c356bfc643594cb6ffb860be4a3bf26fa1a2dd1c4e3bf26442a08334a1ee7eb63fc2801a0bb27881f2bbe0f98cf9a26619b964bb3531d1166  piler-1.4.7.tar.gz
 918c2809db685f676cf3319d687568d380eba3dd43e8c36b00648abb420fe35d036aa1b21d51fe43497aa297546341c1fbdd79ab643bfed4a9f80874a027c446  0001-manticore-conf.patch
 89f4f2136fbe5a7d5106f79533d4b3487ef67d7f8c1added31193114bf4471cff63d1c99bfde23aafb4915e5c00292907b7fd568964ceb8b32da7009f3d4e59b  piler.initd
 3cf50479a0a8b79c1d41f4c4eaa7393630a03f6b007cd8d62b3538bd85d44bc68b949134ad671600073a35428aa0fef7ea2b03ff881f9dc5fdcf444f5e282a01  piler-smtp.initd