diff --git a/community/monkey/APKBUILD b/community/monkey/APKBUILD
index 8e5446a35034af54650da825f5d8dc779a06bbde..0b0adc6b5f1e747b83089576bf08ee048c1ebd11 100644
--- a/community/monkey/APKBUILD
+++ b/community/monkey/APKBUILD
@@ -10,7 +10,7 @@ arch="all"
 license="ASL 2.0"
 depends=""
 depends_dev=""
-makedepends="cmake bash mbedtls-dev findutils"
+makedepends="cmake jemalloc-dev bash mbedtls-dev findutils"
 install=""
 subpackages="$pkgname-doc $pkgname-dev"
 source="http://monkey-project.com/releases/1.6/${pkgname}-${pkgver}.tar.gz"
@@ -25,9 +25,8 @@ build() {
 	./configure \
 		--musl-mode \
 		--no-backtrace \
-		--malloc-libc \
 		--mbedtls-shared \
-		--enable-plugins=tls \
+		--enable-plugins=tls,auth \
 		--default-user=nobody \
 		--prefix=/usr \
 		--libdir=/usr/lib \