diff --git a/community/whois/APKBUILD b/community/whois/APKBUILD
index 6ea2bf60e92de9031725498d5d46dc1b8f9ac82e..67f579610d7256223c96c7e3299366800f166998 100644
--- a/community/whois/APKBUILD
+++ b/community/whois/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Stuart Cardall <developer@it-offshore.co.uk>
 # Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
 pkgname=whois
-pkgver=5.5.8
+pkgver=5.5.9
 pkgrel=0
 pkgdesc="Intelligent WHOIS client by Marco d'Itri"
 url="https://github.com/rfc1036/whois"
@@ -10,7 +10,7 @@ license="GPL-2.0-or-later"
 makedepends="perl libidn-dev gettext-dev"
 options="!check"
 subpackages="$pkgname-doc mkpasswd:_mkpasswd"
-source="$pkgver-$pkgver.tar.gz::https://github.com/rfc1036/whois/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/rfc1036/whois/archive/v$pkgver.tar.gz
 	undefined-libintl.patch
 	enable-sha256-sha512-mkpasswd.patch
 	"
@@ -39,6 +39,6 @@ _mkpasswd() {
 	mv "$pkgdir"/usr/bin/mkpasswd "$subpkgdir"/usr/bin
 }
 
-sha512sums="80f748f34aae9bd6053bc5c9357b7ffa8d713972486b2bf091b04378082dfe13e368de6873fc1de647527e74b07ff5a4198ff1bbd10152097341534668b5cdb7  5.5.8-5.5.8.tar.gz
-efa32ec848e3d3e61481567815e8c02757eab32712eb5a431adb13b59fd359f735eb684fbdf8a5b8334410d17052dc93d65bdda27a328617e2b6772b23717487  undefined-libintl.patch
-66a6b36e4caa00d58ab44c8fb55bfe919994fc6c7631cc283d9f37f9d69bf3e911ab365b27b1720065103e8d7abbf7549dfb260e156c1b52726a8c8b8820c836  enable-sha256-sha512-mkpasswd.patch"
+sha512sums="ab70181220a6d41dd9add04bd81836c89a626de1b45f617e9ab044a666f0ab99a4dee910cff4b0a6a3e47b5e0a7320c2c20f3ff95c2dfc852123d4f672629e16  whois-5.5.9.tar.gz
+7b066a41db4bb1b3753f9f390de05df6bbde27a0436c53ea2de47d87dbaf1182ce3dfc41459b49b3dc079b37ab1a21ea19118a283bd6b062a48ab3f6e2bfbbed  undefined-libintl.patch
+71aaa2cb719fb76514263758b4e731bb6d9213b3174b1e5f1b17a531ececfb9d14acd5e8a2dfc2d776bb15b5cec2b67d9a1bae1c0009a91e8a2149d5b4f5012b  enable-sha256-sha512-mkpasswd.patch"
diff --git a/community/whois/enable-sha256-sha512-mkpasswd.patch b/community/whois/enable-sha256-sha512-mkpasswd.patch
index 643438390caa3aaf01db69fd6ffda943ec6e2849..8592a01c8381f1fdaf117b8b792304e892b34fcf 100644
--- a/community/whois/enable-sha256-sha512-mkpasswd.patch
+++ b/community/whois/enable-sha256-sha512-mkpasswd.patch
@@ -1,7 +1,7 @@
 diff -upr whois-5.4.0.orig/mkpasswd.c whois-5.4.0/mkpasswd.c
 --- whois-5.4.0.orig/mkpasswd.c	2018-11-03 11:37:41.579032463 +0100
 +++ whois-5.4.0/mkpasswd.c	2018-11-03 11:37:47.892515510 +0100
-@@ -108,14 +108,12 @@ static const struct crypt_method methods
+@@ -111,14 +111,12 @@ static const struct crypt_method methods
      { "bcrypt",		"$2b$", 22,	22,	2, "bcrypt" },
      { "bcrypt-a",	"$2a$", 22,	22,	2, "bcrypt (obsolete $2a$ version)" },
  #endif
diff --git a/community/whois/undefined-libintl.patch b/community/whois/undefined-libintl.patch
index 1c9c7c134bb11c70ebdc51bea9e762dc35111352..b96ca9d113744741003d95609b3a10d7ba20bb2a 100644
--- a/community/whois/undefined-libintl.patch
+++ b/community/whois/undefined-libintl.patch
@@ -1,6 +1,6 @@
 --- whois-5.2.15/Makefile
 +++ whois-5.2.15/Makefile.new
-@@ -14,7 +14,7 @@
+@@ -19,7 +19,7 @@
  
  # FreeBSD
  #whois_LDADD += -liconv