diff --git a/community/py3-pytest-forked/APKBUILD b/community/py3-pytest-forked/APKBUILD
index a826a523972e5b3ee0acc26d161cff4f4bf40907..1a8991753a16c15d91f2531063e97cfc5b2cffe5 100644
--- a/community/py3-pytest-forked/APKBUILD
+++ b/community/py3-pytest-forked/APKBUILD
@@ -17,6 +17,10 @@ builddir="$srcdir"/$_pkgname-$pkgver
 replaces="pytest-forked" # Backwards compatibility
 provides="pytest-forked=$pkgver-r$pkgrel" # Backwards compatibility
 
+case "$CARCH" in
+mips*)	options="!check" ;;
+esac
+
 build() {
 	python3 setup.py build
 }