From d9bce0e6298290a34e44210e4d3806134ca8886a Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Sat, 11 Mar 2023 02:36:25 +0000
Subject: [PATCH] main/alpine-base: unprotect os-release

this is useful to not create .apk-new's for something that should never
be edited anyway and always overwritten, but that might be edited by
accident, preventing replacement of a newer release version.
---
 main/alpine-base/APKBUILD | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/main/alpine-base/APKBUILD b/main/alpine-base/APKBUILD
index a81b6eb876b8..4016dfed3576 100644
--- a/main/alpine-base/APKBUILD
+++ b/main/alpine-base/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=alpine-base
 pkgver=3.18_alpha20230208
-pkgrel=0
+pkgrel=1
 pkgdesc="Meta package for minimal alpine base"
 url="https://alpinelinux.org"
 arch="noarch"
@@ -62,6 +62,11 @@ VERSION_ID=$pkgver
 PRETTY_NAME="Alpine Linux $_rel"
 HOME_URL="https://alpinelinux.org/"
 BUG_REPORT_URL="https://gitlab.alpinelinux.org/alpine/aports/-/issues"
+EOF
+
+	mkdir -p "$subpkgdir"/etc/apk/protected_paths.d
+	cat >"$subpkgdir"/etc/apk/protected_paths.d/alpine-release<<EOF
+-etc/os-release
 EOF
 
 	# create secfixes.d repository list
-- 
GitLab