diff --git a/community/cabal/APKBUILD b/community/cabal/APKBUILD
index a992a213fbe7da9c42881a1f893debde03ab1327..35a5695bf583c6614ad551c685f1c7df0f1aff88 100644
--- a/community/cabal/APKBUILD
+++ b/community/cabal/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
 pkgname=cabal
 pkgver=3.0.0.0
-pkgrel=0
+pkgrel=1
 pkgdesc="The Haskell Cabal"
 url="https://haskell.org/"
 arch="x86_64"
diff --git a/community/cloudi/APKBUILD b/community/cloudi/APKBUILD
index 69460024f20e370fad18e67a078edb7308326bef..809e8e6be62e7a3cbc8bfd277b4dd934f095fe83 100644
--- a/community/cloudi/APKBUILD
+++ b/community/cloudi/APKBUILD
@@ -29,7 +29,7 @@
 
 pkgname=cloudi
 pkgver=1.8.0
-pkgrel=1
+pkgrel=2
 pkgdesc="Cloud computing framework for efficient, scalable, and stable soft-realtime event processing."
 url="https://cloudi.org/"
 license="MIT"
diff --git a/community/ecl/APKBUILD b/community/ecl/APKBUILD
index 8637f2e5e973b66e0eed2ecd896898ac50b8b8ff..bc3ae55b851f43101b44292c273ea44cba3033eb 100644
--- a/community/ecl/APKBUILD
+++ b/community/ecl/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Lucas Ramage <ramage.lucas@openmailbox.org>
 pkgname=ecl
 pkgver=16.1.3
-pkgrel=3
+pkgrel=4
 pkgdesc="Embeddable Common Lisp"
 # not compatible with soft-float archs (like mips)
 arch="all !mips !mips64"
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index 532f08fd5932e8c661a2c637c87e52b46b3dbd52..9c8a6f8d0a4fcb998b9cb39aaa0bc897a9248429 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=firefox-esr
 pkgver=68.7.0
-pkgrel=0
+pkgrel=1
 pkgdesc="Firefox web browser - Extended Support Release"
 url="https://www.mozilla.org/en-US/firefox/organizations/"
 # limited by rust and cargo on mips s390x, fails to build on armhf
diff --git a/community/firefox/APKBUILD b/community/firefox/APKBUILD
index e4eaa93c6ecdf757d7ea3488bf84f20c6ca072e0..fbe994ce9102d722830891657c07af49bd3dec84 100644
--- a/community/firefox/APKBUILD
+++ b/community/firefox/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=firefox
 pkgver=75.0
-pkgrel=0
+pkgrel=1
 pkgdesc="Firefox web browser"
 url="https://www.firefox.com/"
 # Limited on:
diff --git a/community/ghc/APKBUILD b/community/ghc/APKBUILD
index 1b5eae50232350751d46984504ee34aa3e214816..5c3b5da68eb7607efdb29976f2df63ffc661dcbf 100644
--- a/community/ghc/APKBUILD
+++ b/community/ghc/APKBUILD
@@ -2,7 +2,7 @@
 pkgname=ghc
 pkgver=8.6.5
 _llvmver=9
-pkgrel=3
+pkgrel=4
 # Normal non rc candidate
 _urlprefix="$pkgver"
 _pkgprefix="$pkgname-$pkgver"
diff --git a/community/java-jna/APKBUILD b/community/java-jna/APKBUILD
index 9a532d109aac270a40e8316364c7f3c7404b0fcf..57abdd5ee115a0e713186d96ad4b60ae39cba4fd 100644
--- a/community/java-jna/APKBUILD
+++ b/community/java-jna/APKBUILD
@@ -3,7 +3,7 @@
 pkgname=java-jna
 _pkgname=${pkgname#java-}
 pkgver=5.5.0
-pkgrel=0
+pkgrel=1
 pkgdesc="JNA provides Java programs easy access to native shared libraries."
 url="https://github.com/java-native-access/jna"
 arch="all !mips !mips64"
diff --git a/community/llvm5/APKBUILD b/community/llvm5/APKBUILD
index c53fd1ce8346a767da67b9430f305cded748c652..6d370ce2299d5df5526f8029c6ae534fb59d9072 100644
--- a/community/llvm5/APKBUILD
+++ b/community/llvm5/APKBUILD
@@ -6,7 +6,7 @@ _pkgname=llvm
 pkgver=5.0.2
 _majorver=${pkgver%%.*}
 pkgname=$_pkgname$_majorver
-pkgrel=3
+pkgrel=4
 pkgdesc="Low Level Virtual Machine compiler system, version $_majorver"
 arch="all !mips !mips64"
 url="https://llvm.org/"
diff --git a/community/llvm8/APKBUILD b/community/llvm8/APKBUILD
index e9ec1844007a81d9694407cbf84b013c81616fff..ef40c2bf13c622c2f0e23563e7cb2c5415a5956f 100644
--- a/community/llvm8/APKBUILD
+++ b/community/llvm8/APKBUILD
@@ -8,7 +8,7 @@ _pkgname=llvm
 pkgver=8.0.1
 _majorver=${pkgver%${pkgver##[0-9]}}
 pkgname=$_pkgname$_majorver
-pkgrel=3
+pkgrel=4
 pkgdesc="Low Level Virtual Machine compiler system, version $_majorver"
 arch="all"
 url="https://llvm.org/"
diff --git a/community/lua-lgi/APKBUILD b/community/lua-lgi/APKBUILD
index cfb460b7ad769f5ae6fbc3c4ce6fbf051dbfa6b3..c735ef2be8b006e7e98ec69fe5213849598bab72 100644
--- a/community/lua-lgi/APKBUILD
+++ b/community/lua-lgi/APKBUILD
@@ -3,7 +3,7 @@
 _luaversions="5.1 5.2 5.3"
 pkgname=lua-lgi
 pkgver=0.9.2
-pkgrel=0
+pkgrel=1
 pkgdesc="Dynamic Lua binding to GObject libraries using GObject-Introspection"
 url="https://github.com/pavouk/lgi"
 arch="all"
diff --git a/community/mozjs68/APKBUILD b/community/mozjs68/APKBUILD
index ab1590002cecdcd35400834305c45555a9e5bc33..29b91f053d7f949ff480aa660340d5cb83217fc2 100644
--- a/community/mozjs68/APKBUILD
+++ b/community/mozjs68/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=mozjs68
 pkgver=68.6.0
-pkgrel=2
+pkgrel=3
 pkgdesc="Standalone Mozilla JavaScript engine"
 url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
 arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # limited by rust and cargo
diff --git a/community/ruby-ffi/APKBUILD b/community/ruby-ffi/APKBUILD
index dc25f79b062861821d8212b1da28713a90b5e351..5b5b2aadcd254675561c3776badb1b210adf7594 100644
--- a/community/ruby-ffi/APKBUILD
+++ b/community/ruby-ffi/APKBUILD
@@ -3,7 +3,7 @@
 pkgname=ruby-ffi
 _gemname=ffi
 pkgver=1.12.2
-pkgrel=0
+pkgrel=1
 pkgdesc="Ruby FFI library"
 url="https://github.com/ffi/ffi"
 arch="all"
diff --git a/community/shellcheck/APKBUILD b/community/shellcheck/APKBUILD
index dc2b4bde957a31522f77cfc0973f1e952c013ef5..2a05f2b8ae41d17b3b93b9ea3058e61712ff22de 100644
--- a/community/shellcheck/APKBUILD
+++ b/community/shellcheck/APKBUILD
@@ -5,6 +5,8 @@ pkgrel=1
 pkgdesc="a static analysis tool for shell scripts"
 url="https://github.com/koalaman/shellcheck"
 arch="x86_64" # Limited by GHC / Cabal
+# Fails to build shellcheck.1
+arch="" 
 license="GPL-3.0"
 makedepends="cabal ghc"
 subpackages="$pkgname-doc"
diff --git a/main/glib/APKBUILD b/main/glib/APKBUILD
index e7e786d3b4979b9de597c90fc4b63b5b3d4838cf..a48dde1ee30f0e2bc340b99581f5476aefc365cf 100644
--- a/main/glib/APKBUILD
+++ b/main/glib/APKBUILD
@@ -4,7 +4,7 @@
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=glib
 pkgver=2.64.2
-pkgrel=0
+pkgrel=1
 pkgdesc="Common C routines used by Gtk+ and other libs"
 url="https://developer.gnome.org/glib/"
 arch="all"
diff --git a/main/gobject-introspection/APKBUILD b/main/gobject-introspection/APKBUILD
index b52e1df204b9b66b0f88e69cdc8b68869af82127..9fd2ee5117021eb69a685560d8108a1697e5943e 100644
--- a/main/gobject-introspection/APKBUILD
+++ b/main/gobject-introspection/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=gobject-introspection
 pkgver=1.64.1
-pkgrel=0
+pkgrel=1
 pkgdesc="Introspection system for GObject-based libraries"
 url="https://wiki.gnome.org/action/show/Projects/GObjectIntrospection"
 arch="all"
diff --git a/main/guile/APKBUILD b/main/guile/APKBUILD
index 9193fa1a97d2c25be9eedca59e775d15ee813deb..00dce413947c888a2ce7e8081fe23da2b552bc12 100644
--- a/main/guile/APKBUILD
+++ b/main/guile/APKBUILD
@@ -6,7 +6,7 @@
 
 pkgname=guile
 pkgver=2.0.14
-pkgrel=0
+pkgrel=1
 pkgdesc="Guile is a portable, embeddable Scheme implementation written in C"
 url="https://www.gnu.org/software/guile/"
 arch="all"
diff --git a/main/llvm10/APKBUILD b/main/llvm10/APKBUILD
index 46de6cb695ab850f3abdb02bc014f77211f48461..ed10b617dd0ad5cb08fce5adb0f211867b547504 100644
--- a/main/llvm10/APKBUILD
+++ b/main/llvm10/APKBUILD
@@ -8,7 +8,7 @@ _pkgname=llvm
 pkgver=10.0.0
 _majorver=${pkgver%%.*}
 pkgname=$_pkgname$_majorver
-pkgrel=0
+pkgrel=1
 pkgdesc="Low Level Virtual Machine compiler system, version $_majorver"
 arch="all"
 url="https://llvm.org/"
diff --git a/main/llvm9/APKBUILD b/main/llvm9/APKBUILD
index fb9803112c5e9099f61e68c15072ee5abc280d31..9a8be63d5e78c2ea796aefce720b60c5c6bff356 100644
--- a/main/llvm9/APKBUILD
+++ b/main/llvm9/APKBUILD
@@ -8,7 +8,7 @@ _pkgname=llvm
 pkgver=9.0.1
 _majorver=${pkgver%${pkgver##[0-9]}}
 pkgname=$_pkgname$_majorver
-pkgrel=1
+pkgrel=2
 pkgdesc="Low Level Virtual Machine compiler system, version $_majorver"
 arch="all"
 url="https://llvm.org/"
diff --git a/main/mozjs60/APKBUILD b/main/mozjs60/APKBUILD
index 7b4a237534435a1437751d645b369abb8bd47dc4..32b4aed8ca32dcd657f545ef6630f47d63c6a55d 100644
--- a/main/mozjs60/APKBUILD
+++ b/main/mozjs60/APKBUILD
@@ -3,7 +3,7 @@
 pkgname=mozjs60
 pkgver=60.9.0
 _majver=${pkgver%%.*}
-pkgrel=3
+pkgrel=4
 pkgdesc="standalone mozilla javascript engine"
 url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/60"
 arch="all"
diff --git a/main/p11-kit/APKBUILD b/main/p11-kit/APKBUILD
index 56b018fe27e6b762d550a88e2538f27b03263ec1..725867b4ad89cdfdd30b5d1bad044bb262e8798e 100644
--- a/main/p11-kit/APKBUILD
+++ b/main/p11-kit/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
 pkgname=p11-kit
 pkgver=0.23.20
-pkgrel=2
+pkgrel=3
 pkgdesc="Library for loading and sharing PKCS#11 modules"
 url="https://p11-glue.freedesktop.org/"
 arch="all"
diff --git a/main/py3-cffi/APKBUILD b/main/py3-cffi/APKBUILD
index ecabf6a657683c3110b7743efd98c016e24e60a1..a5b36fa9f13bff7c6e4016279a812244b629fa41 100644
--- a/main/py3-cffi/APKBUILD
+++ b/main/py3-cffi/APKBUILD
@@ -3,7 +3,7 @@
 pkgname=py3-cffi
 _pkgname=cffi
 pkgver=1.14.0
-pkgrel=0
+pkgrel=1
 pkgdesc="A foreign function interface for calling C code from Python3"
 url="http://cffi.readthedocs.org/"
 arch="all"
diff --git a/main/py3-gobject3/APKBUILD b/main/py3-gobject3/APKBUILD
index 2a1c5227cc529d58316071e9bba8a0d5101b4d27..e65c1ebb2fdde3bdcb6b3568b5873643d2e99da3 100644
--- a/main/py3-gobject3/APKBUILD
+++ b/main/py3-gobject3/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Rasmus Thomsen <oss@cogitri.dev>
 pkgname=py3-gobject3
 pkgver=3.36.0
-pkgrel=0
+pkgrel=1
 pkgdesc="Python bindings for the GObject library"
 url="https://wiki.gnome.org/Projects/PyGObject/"
 arch="all"
diff --git a/main/python3/APKBUILD b/main/python3/APKBUILD
index 2121d7722946f76e6ee4d3c6ee673a1cf009b9c3..13e23a651b06eba33b8a00c082c1853c26887a52 100644
--- a/main/python3/APKBUILD
+++ b/main/python3/APKBUILD
@@ -6,7 +6,7 @@ pkgname=python3
 pkgver=3.8.2
 _bluez_ver=5.53
 _basever="${pkgver%.*}"
-pkgrel=3
+pkgrel=4
 pkgdesc="A high-level scripting language"
 url="https://www.python.org/"
 arch="all"
diff --git a/main/ruby/APKBUILD b/main/ruby/APKBUILD
index c7ce5dd10afb78cfa2a87ca44080fdf446a6441c..1f782b885a9bb85e83907cbe647af0cc9243d78f 100644
--- a/main/ruby/APKBUILD
+++ b/main/ruby/APKBUILD
@@ -36,7 +36,7 @@
 pkgname=ruby
 pkgver=2.6.6
 _abiver="${pkgver%.*}.0"
-pkgrel=2
+pkgrel=3
 pkgdesc="An object-oriented language for quick and easy programming"
 url="https://www.ruby-lang.org/"
 arch="all"
diff --git a/main/wayland/APKBUILD b/main/wayland/APKBUILD
index e078b69d40560d2f316f22257d783751d8d81c98..28ada71eaf2605d24dc93ef706bdcefff426e3bb 100644
--- a/main/wayland/APKBUILD
+++ b/main/wayland/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Valery Kartel <valery.kartel@gmail.com>
 pkgname=wayland
 pkgver=1.18.0
-pkgrel=1
+pkgrel=2
 pkgdesc="A computer display server protocol"
 url="https://wayland.freedesktop.org"
 arch="all"
diff --git a/testing/gforth/APKBUILD b/testing/gforth/APKBUILD
index b6cff3e3621c454747ece4bf042c8a74a58ac0cd..c8589b77c232c8e59f3760e2f3778f2967342fa6 100644
--- a/testing/gforth/APKBUILD
+++ b/testing/gforth/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Milan P. Stanić <mps@arvanta.net>
 pkgname=gforth
 pkgver=0.7.3
-pkgrel=1
+pkgrel=2
 pkgdesc="Fast and portable implementation of the ANS Forth language"
 url="http://www.gnu.org/software/gforth/"
 arch="all !x86" # build fail on x86
diff --git a/testing/idris/APKBUILD b/testing/idris/APKBUILD
index ed2fffb40abf9b0f7c539b250ceedc3312aeff81..b8a6cc63ea31750ee08b52969bea90068d506473 100644
--- a/testing/idris/APKBUILD
+++ b/testing/idris/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
 pkgname=idris
 pkgver=1.3.0
-pkgrel=1
+pkgrel=2
 pkgdesc="A Language with Dependent Types"
 url="https://www.idris-lang.org/"
 # Note: same as ghc, if it gets ported elsewhere this should run too.
diff --git a/testing/llvm6/APKBUILD b/testing/llvm6/APKBUILD
index 2798d4e2608770955d6a80a2e99f6ba1b4357df9..928a27d008f1bc51bb71e59c9ab0b99e35053ec4 100644
--- a/testing/llvm6/APKBUILD
+++ b/testing/llvm6/APKBUILD
@@ -6,7 +6,7 @@ _pkgname=llvm
 pkgver=6.0.1
 _majorver=${pkgver%%.*}
 pkgname=$_pkgname$_majorver
-pkgrel=5
+pkgrel=6
 pkgdesc="Low Level Virtual Machine compiler system, version $_majorver"
 arch="all"
 url="https://llvm.org/"
diff --git a/testing/micropython/APKBUILD b/testing/micropython/APKBUILD
index f496f46ac281c67b366d3e22980892a81eec43c8..37c5938afdd4db54095bb9e3c10efa62ac847f4a 100644
--- a/testing/micropython/APKBUILD
+++ b/testing/micropython/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Marian <marian.buschsieweke@ovgu.de>
 pkgname=micropython
 pkgver=1.12
-pkgrel=0
+pkgrel=1
 pkgdesc="A lean and efficient Python implementation for MCUs and constrained systems"
 url="https://www.micropython.org/"
 
diff --git a/testing/moarvm/APKBUILD b/testing/moarvm/APKBUILD
index 9f7a77c8feae8fba1bc76ef6a6f2e37d3d0e206f..86ad20d5b1601f7281ed615c93603d2fab257767 100644
--- a/testing/moarvm/APKBUILD
+++ b/testing/moarvm/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Curt Tilmes <Curt.Tilmes@nasa.gov>
 pkgname=moarvm
 pkgver=2019.07.1
-pkgrel=0
+pkgrel=1
 pkgdesc="A VM for NQP And Rakudo Perl 6"
 url="http://moarvm.org/"
 arch="all"
diff --git a/testing/polyml/APKBUILD b/testing/polyml/APKBUILD
index eef15e8bd44ad781972b56689474716d4be89c12..b2349d62b80aa8c8a257aa2470dccfa8db3d3c9c 100644
--- a/testing/polyml/APKBUILD
+++ b/testing/polyml/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer:
 pkgname=polyml
 pkgver=5.8
-pkgrel=0
+pkgrel=1
 pkgdesc="ML97 compatible Standard ML implementation"
 url="https://www.polyml.org/"
 arch="all !aarch64 !ppc64le !s390x"
diff --git a/testing/seamonkey/APKBUILD b/testing/seamonkey/APKBUILD
index 5da3b5f293f935494f9b27ec34d9b37e7a679aa3..0dce3e1f78fefcf0ebdeb650e448f20d28c75996 100644
--- a/testing/seamonkey/APKBUILD
+++ b/testing/seamonkey/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Marc Vertes <mvertes@free.fr>
 pkgname=seamonkey
 pkgver=2.49.5
-pkgrel=2
+pkgrel=3
 pkgdesc="all-in-one internet application suite"
 url="https://www.seamonkey-project.org/"
 arch="x86_64 x86"
diff --git a/testing/thunderbird/APKBUILD b/testing/thunderbird/APKBUILD
index df862e149ee649fee2c70ee5cf2f96d72dbb1c27..ae4f23474871839c872a57b6b7b04537b929f66d 100644
--- a/testing/thunderbird/APKBUILD
+++ b/testing/thunderbird/APKBUILD
@@ -5,7 +5,7 @@ pkgname=thunderbird
 pkgver=68.6.0
 _pkgver=$pkgver
 _xulver=$pkgver
-pkgrel=2
+pkgrel=3
 pkgdesc="Thunderbird email client"
 url="https://www.thunderbird.net/"
 arch="all !s390x !armhf !mips !mips64" # limited by rust and cargo. Fails on armhf due to bad assembly