From d7dcd82c86422eafa795ff5d741095f620e88cc0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
Date: Wed, 7 Feb 2018 19:06:55 +0000
Subject: [PATCH] testing/py-distorm3: new aport

The goal of diStorm3 is to decode x86/AMD64 binary streams and return a structure that describes each instruction
https://pypi.python.org/pypi/distorm3
---
 testing/py-distorm3/APKBUILD | 43 ++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
 create mode 100644 testing/py-distorm3/APKBUILD

diff --git a/testing/py-distorm3/APKBUILD b/testing/py-distorm3/APKBUILD
new file mode 100644
index 000000000000..6de78288c159
--- /dev/null
+++ b/testing/py-distorm3/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=py-distorm3
+pkgver=3.3.4
+pkgrel=0
+pkgdesc="The goal of diStorm3 is to decode x86/AMD64 binary streams and return a structure that describes each instruction"
+url="https://pypi.python.org/pypi/distorm3"
+arch="all"
+license="MIT"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://github.com/gdabah/distorm/releases/download/v$pkgver/distorm3-$pkgver.zip"
+builddir="$srcdir/${pkgname/py-/}-$pkgver"
+
+build() {
+	cd "$builddir"
+	python2 setup.py build
+	python3 setup.py build
+}
+
+package() {
+	mkdir -p "$pkgdir"
+}
+
+_py2() {
+	replaces="$pkgname"
+	_py python2
+}
+
+_py3() {
+	_py python3
+}
+
+_py() {
+	local python="$1"
+	pkgdesc="$pkgdesc (for $python)"
+	install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+	cd "$builddir"
+	$python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="ac989fcbfa857f86fa5cd6c054a2f5e7bd2d7ccaf345950062dd70542e5e4ae5d179cda58e721f54b889549c63cbdfc6ed985a35f767dbbd3db4577fdc592ec6  distorm3-3.3.4.zip"
-- 
GitLab