Commit d52e9201 authored by Natanael Copa's avatar Natanael Copa

main/libgnome: build fix for glib-2.36 and split -lang

parent 216c819d
......@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgnome
pkgver=2.32.1
pkgrel=3
pkgrel=4
pkgdesc="GNOME base library"
url="http://www.gnome.org/"
arch="all"
......@@ -11,8 +11,9 @@ depends=
depends_dev="gtk+-dev gconf-dev libcanberra-dev gnome-vfs-dev libbonobo-dev"
makedepends="$depends_dev"
install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
subpackages="$pkgname-dev $pkgname-doc"
source="http://ftp.acc.umu.se/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://ftp.acc.umu.se/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
glib-2.36.patch"
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
......@@ -29,7 +30,7 @@ build() {
cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--disable-scrollkeeper
|| return 1
make || return 1
}
......@@ -41,4 +42,9 @@ package() {
find "$pkgdir" -name '*.la' -delete
}
md5sums="a4345e6087ae6195d65a4674ffdca559 libgnome-2.32.1.tar.bz2"
md5sums="a4345e6087ae6195d65a4674ffdca559 libgnome-2.32.1.tar.bz2
67e4f7b0acea497406f06b04df608982 glib-2.36.patch"
sha256sums="b2c63916866485793b87398266dd7778548c1734923c272a94d84ee011b6f7a4 libgnome-2.32.1.tar.bz2
a0895e37c81f5f45c0f05931416ddbad6284735eded43b75dc8d0947a5bddd55 glib-2.36.patch"
sha512sums="f94e603255a93e73249e0fd9ed5604d732b44ad46f3cc3065afb46fc6162f6cf29304f49440b5c06303b8e68608b6fd16236076813febb5f1cbdcde4bfc3b3e3 libgnome-2.32.1.tar.bz2
1c7ed4c8012584c980f80ce12ee2e8ab1340432766b35b3139844927e183ef33d09a02eb7ec10bb8c7312950d2c1d0d1bdeef92512cded2278223470b2936087 glib-2.36.patch"
$NetBSD: patch-libgnome_Makefile.in,v 1.1 2013/04/19 20:37:41 prlw1 Exp $
Avoid compilation error caused by use of deprecated g_thread API
--- ./libgnome/Makefile.in.orig 2013-04-19 20:27:06.000000000 +0000
+++ ./libgnome/Makefile.in
@@ -311,7 +311,6 @@ INCLUDES = \
-I$(srcdir)/.. \
$(WARN_CFLAGS) \
$(LIBGNOME_CFLAGS) \
- -DG_DISABLE_DEPRECATED \
-DLIBGNOME_PREFIX=\""$(prefix)"\" \
-DLIBGNOME_LIBDIR=\""$(libdir)"\" \
-DLIBGNOME_DATADIR=\""$(datadir)"\" \
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment