diff --git a/main/lld/APKBUILD b/main/lld/APKBUILD
index 3f15a9e8250a53174c9d762ef0cb274981d67fe7..4f4659a35e87f126537350ebafe0d4114ac6e235 100644
--- a/main/lld/APKBUILD
+++ b/main/lld/APKBUILD
@@ -4,7 +4,7 @@
 # Maintainer: psykose <alice@ayaya.dev>
 pkgname=lld
 pkgver=16.0.4
-pkgrel=0
+pkgrel=1
 _llvmver=${pkgver%%.*}
 pkgdesc="The LLVM Linker"
 url="https://llvm.org/"
@@ -27,6 +27,7 @@ makedepends="
 	llvm-libunwind-dev
 	patchelf
 	samurai
+	scudo-malloc
 	zlib-dev
 	"
 checkdepends="gtest-dev bash llvm$_llvmver-test-utils"
@@ -71,13 +72,9 @@ package() {
 	DESTDIR="$pkgdir" cmake --install build
 	install -Dm644 "$builddir"/docs/ld.lld.1 -t "$pkgdir"/usr/share/man/man1/
 
-	case "$CARCH" in
-	aarch64|arm*|x86|x86_64|ppc64le|riscv64)
-		# we have the scudo allocator on these arches, so link lld to it to
-		# significantly improve performance, especially in LTO contexts
-		patchelf --add-needed libscudo.so "$pkgdir"/usr/bin/lld
-		;;
-	esac
+	# we have the scudo allocator available, so link lld to it to
+	# significantly improve performance, especially in LTO contexts
+	patchelf --add-needed libscudo.so "$pkgdir"/usr/bin/lld
 }
 
 sha512sums="