diff --git a/testing/py3-passlib/APKBUILD b/testing/py3-passlib/APKBUILD
index 09e78fbea0a8c7fa94941331d488a623e3264e9d..2c07010e4c3ef04f2ffc6c9eb9ebac35b2a90521 100644
--- a/testing/py3-passlib/APKBUILD
+++ b/testing/py3-passlib/APKBUILD
@@ -10,9 +10,7 @@ license="BSD-3-Clause"
 depends="python3"
 makedepends="py3-setuptools"
 checkdepends="py3-nose py3-scrypt"
-source="https://files.pythonhosted.org/packages/source/p/passlib/passlib-$pkgver.tar.gz
-	skip-bsdi_crypt-test.patch
-	"
+source="https://files.pythonhosted.org/packages/source/p/passlib/passlib-$pkgver.tar.gz"
 builddir="$srcdir"/passlib-$pkgver
 
 replaces="py-passlib" # Backwards compatibility
@@ -30,5 +28,4 @@ package() {
 	python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
 }
 
-sha512sums="1ea0654b177b5ab2e1a7e5c3949642c34805ace6e4e4a0f82fafdb3f374edd99c667906ce598c335b668da049860648d5cbebb3e62d775898d5b0cb8cfc7bf53  passlib-1.7.2.tar.gz
-cdf085a94be88140dff421128bbeb9f4c05d13ae8c14ad80e7ab6d9edf2be19b0ad010eb18a5eccd3eefa679c4f634c6f98753571df72a1fc387343331fa8bae  skip-bsdi_crypt-test.patch"
+sha512sums="1ea0654b177b5ab2e1a7e5c3949642c34805ace6e4e4a0f82fafdb3f374edd99c667906ce598c335b668da049860648d5cbebb3e62d775898d5b0cb8cfc7bf53  passlib-1.7.2.tar.gz"
diff --git a/testing/py3-passlib/skip-bsdi_crypt-test.patch b/testing/py3-passlib/skip-bsdi_crypt-test.patch
deleted file mode 100644
index 094ccd141224b11d290535c161eefa0288cc91d0..0000000000000000000000000000000000000000
--- a/testing/py3-passlib/skip-bsdi_crypt-test.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- passlib-1.7.1/passlib/tests/utils.py
-+++ passlib-1.7.1/passlib/tests/utils.py.new
-@@ -3171,8 +3171,7 @@
-             self.fail("expected %r platform would have native support "
-                       "for %r" % (platform, self.handler.name))
-         else:
--            self.fail("did not expect %r platform would have native support "
--                      "for %r" % (platform, self.handler.name))
-+            raise self.skipTest("varied support on %r platform" % platform)
- 
-     #===================================================================
-     # fuzzy verified support -- add new verified that uses os crypt()