Commit d189e1ab authored by Natanael Copa's avatar Natanael Copa

community/py3-qt5: build more bindings

needed by cutebrowser
parent 3815b72b
......@@ -3,14 +3,23 @@
pkgname=py3-qt5
_pkgname=PyQt5
pkgver=5.10.1
pkgrel=0
pkgrel=1
pkgdesc="A set of Python 3 bindings for the Qt toolkit"
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
arch="all"
license="GPL-2.0-or-later"
depends="py-sip"
makedepends="python3-dev py-dbus-dev py-sip-dev
qt5-qtbase-dev libx11-dev qt5-qtsvg-dev qt5-qtwebsockets-dev"
qt5-qtbase-dev libx11-dev qt5-qtsvg-dev qt5-qtwebsockets-dev
py-opengl qt5-qtconnectivity-dev qt5-qtmultimedia-dev qt5-qttools-dev
qt5-qtserialport-dev qt5-qtx11extras-dev qt5-qtdeclarative-dev
"
# not all arches support qtwebengine
case "$CARCH" in
armhf|aarch64|x86_64)
makedepends="$makedepends qt5-qtwebengine-dev" ;;
esac
source="https://sourceforge.net/projects/pyqt/files/$_pkgname/PyQt-$pkgver/${_pkgname}_gpl-$pkgver.zip"
builddir="${srcdir}/${_pkgname}_gpl-${pkgver}"
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment