diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index bd89243b377d0cfe6f8042d4f8b93eed0a881b6b..ca777d95ca0e190810709118813b1c20c4ba1116 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=go
 # go binaries are statically linked, security updates require rebuilds
-pkgver=1.17.8
+pkgver=1.18
 pkgrel=0
 pkgdesc="Go programming language compiler"
 url="https://go.dev/"
@@ -14,8 +14,6 @@ makedepends="bash"
 checkdepends="binutils-gold"
 subpackages="$pkgname-doc"
 source="https://go.dev/dl/go$pkgver.src.tar.gz
-	disable-flaky-sync-test.patch
-	disable-flaky-gc-test.patch
 	allow-unshare-to-return-enosys.patch
 	"
 case "$CARCH" in
@@ -198,8 +196,6 @@ package() {
 }
 
 sha512sums="
-21d5c51ce62bc3b987dd5bf7c6b7e1a934fe40582bfbbe99ca80c26d41253e796a4b9d02c571f1e5ab3fd7c3950175e23b9929b0d934f421c96a6d6128c44668  go1.17.8.src.tar.gz
-988a436727aefc5124702bd70cb01bb457a921affcdd03e17f78937685482e899080d95baf125e054d1f634dae5c747d05a3662f1f4f462b87965b06270c788f  disable-flaky-sync-test.patch
-ab4aa83d8a9bf10bbb93ad029095b47c6eea7d5532703d84449884039116e07897871649feb1df8128f10257cbdb5d7eb03820ab0f1a3f60315e195302f6e516  disable-flaky-gc-test.patch
+f10356df9099e4d027415be5c73bd2551f2f941a31feb21e1ccc03b7d8faa1844f0a639a508e990712e11ec335675e57504edb323fa1eee63e1d09b8523b3b0d  go1.18.src.tar.gz
 6017caacf77c2911e9e882878fdaa2ed066b76b7e97b2ad776bc33d96b21cabc802966473946642c86a8f985c69adcc5e7ea61684f6d0dbacd468a6aad687229  allow-unshare-to-return-enosys.patch
 "
diff --git a/community/go/disable-flaky-gc-test.patch b/community/go/disable-flaky-gc-test.patch
deleted file mode 100644
index 038fb27bfbef830e0248b828c3946cf334892aeb..0000000000000000000000000000000000000000
--- a/community/go/disable-flaky-gc-test.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-See https://github.com/golang/go/issues/37331
-
-diff -upr go.orig/src/runtime/gc_test.go go/src/runtime/gc_test.go
---- go.orig/src/runtime/gc_test.go	2020-06-01 00:59:57.179164980 +0200
-+++ go/src/runtime/gc_test.go	2020-06-01 01:00:52.282339799 +0200
-@@ -15,9 +15,11 @@ import (
- 	"testing"
- 	"time"
- 	"unsafe"
-+	"internal/testenv"
- )
- 
- func TestGcSys(t *testing.T) {
-+	testenv.SkipFlaky(t, 37331)
- 	if os.Getenv("GOGC") == "off" {
- 		t.Skip("skipping test; GOGC=off in environment")
- 	}
diff --git a/community/go/disable-flaky-sync-test.patch b/community/go/disable-flaky-sync-test.patch
deleted file mode 100644
index 76fa1377bb96b664ac378b6f28407f1c40516900..0000000000000000000000000000000000000000
--- a/community/go/disable-flaky-sync-test.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-See https://github.com/golang/go/issues/20072
-
-diff --git a/src/sync/waitgroup_test.go b/src/sync/waitgroup_test.go
-index 4ab438c..5f4fc80 100644
---- a/src/sync/waitgroup_test.go
-+++ b/src/sync/waitgroup_test.go
-@@ -10,6 +10,7 @@ import (
- 	. "sync"
- 	"sync/atomic"
- 	"testing"
-+	"internal/testenv"
- )
- 
- func testWaitGroup(t *testing.T, wg1 *WaitGroup, wg2 *WaitGroup) {
-@@ -84,6 +85,7 @@ func pollUntilEqual(v *uint32, target uint32) {
- }
- 
- func TestWaitGroupMisuse2(t *testing.T) {
-+	testenv.SkipFlaky(t, 20072)
- 	knownRacy(t)
- 	if runtime.NumCPU() <= 4 {
- 		t.Skip("NumCPU<=4, skipping: this test requires parallelism")