diff --git a/testing/muon/APKBUILD b/community/muon/APKBUILD
similarity index 92%
rename from testing/muon/APKBUILD
rename to community/muon/APKBUILD
index ae0793078fae10278f893995ad1568e930694d14..a756c489fedf4f988b18cf9da292076cd3b01c3d 100644
--- a/testing/muon/APKBUILD
+++ b/community/muon/APKBUILD
@@ -80,10 +80,11 @@ build() {
 }
 
 check() {
-	build-wrap/muon -C build-wrap test -j "${JOBS:-0}" -R -d dots
-	rm -r subprojects/meson-tests
-	cp -a subprojects/meson-tests.orig subprojects/meson-tests
-	build/muon -C build test -j "${JOBS:-0}" -R -d dots
+	local d; for d in build-wrap build; do
+		$d/muon -C $d test -j "${JOBS:-0}" -R -d dots
+		rm -r subprojects/meson-tests
+		cp -a subprojects/meson-tests.orig subprojects/meson-tests
+	done
 }
 
 package() {
diff --git a/testing/muon/abuild-muon b/community/muon/abuild-muon
similarity index 100%
rename from testing/muon/abuild-muon
rename to community/muon/abuild-muon
diff --git a/testing/muon/pkgconfig-gen-test.patch b/community/muon/pkgconfig-gen-test.patch
similarity index 100%
rename from testing/muon/pkgconfig-gen-test.patch
rename to community/muon/pkgconfig-gen-test.patch