diff --git a/community/greetd-phrog/APKBUILD b/community/greetd-phrog/APKBUILD
index 14bf234d1b046b68156d7f0cb9b0e3f137dc6d94..3c9613983cad0d6e34c7f88bbfe2acfe9dcd2792 100644
--- a/community/greetd-phrog/APKBUILD
+++ b/community/greetd-phrog/APKBUILD
@@ -1,11 +1,10 @@
 # Maintainer: Sam Day <me@samcday.com>
 pkgname=greetd-phrog
-pkgver=0.42.0
-pkgrel=1
+pkgver=0.43.0
+pkgrel=0
 pkgdesc="Mobile device greeter"
 url=https://github.com/samcday/phrog
 # s390x: blocked by greetd & phosh
-# ppc64le: blocked by phosh
 # armhf: blocked by phosh
 arch="all !s390x !armhf"
 license="GPL-3.0-only"
@@ -21,11 +20,13 @@ makedepends="
 checkdepends="xvfb-run"
 
 source="https://github.com/samcday/phrog/archive/$pkgver/phrog-$pkgver.tar.gz
-	libphosh-0.43.patch
+	libphosh-0.0.5.patch
 	"
 subpackages="$pkgname-schemas::noarch"
 builddir="$srcdir/phrog-$pkgver"
-options="net" # cargo fetch
+# net: cargo fetch
+# !check: fail https://github.com/samcday/phrog/commit/6be76139689e9809951dcee981fec1f299b823d2
+options="net !check"
 
 export RUSTFLAGS="$RUSTFLAGS --remap-path-prefix=$builddir=/build/"
 
@@ -54,6 +55,6 @@ schemas() {
 	amove usr/share/glib-2.0/schemas
 }
 sha512sums="
-1db152d53d99fe36e3e3a027b008745d62b27b44b355372609b343665b54ba2fcee8943ec20f4570d963e3a92ea0966336949b0dcd94a6417255bb1f53524a36  phrog-0.42.0.tar.gz
-00962de17ea6bc215e18fa5c613f663bb249632d4392bf9a5a36cb15315101983feea34b04ee8bc5c5b5e4290d9e73137ee561042a8e4bfd94caad1219a93d8f  libphosh-0.43.patch
+5a601826505fb7365dc16d47c84d4aadf9af40b529a50256b13c7b423cc910f850033cf01ec199b423301ba8525b7a34b5a1eb055d08023913656ac59d76d007  phrog-0.43.0.tar.gz
+050dcf8706f318c7de3488c4c17703dc1b4c80773e1983a1a2d2e8808e1b7c9b25f7ca6c9ac977ed309b63757cc17c0fdc203c6df9eaecec7a8eb241716ee809  libphosh-0.0.5.patch
 "
diff --git a/community/greetd-phrog/libphosh-0.0.5.patch b/community/greetd-phrog/libphosh-0.0.5.patch
new file mode 100644
index 0000000000000000000000000000000000000000..4b16895d04f43acd38cb9719cf438452c5c004b6
--- /dev/null
+++ b/community/greetd-phrog/libphosh-0.0.5.patch
@@ -0,0 +1,39 @@
+Upstream-commit: https://github.com/samcday/phrog/commit/b03b748dc2d55aaf01a960f87dd9f6ce5817a5fc
+
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -1063,9 +1063,9 @@ dependencies = [
+ 
+ [[package]]
+ name = "libphosh"
+-version = "0.0.4"
++version = "0.0.5"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "fe123fc484331be2a8e148321cdf71750c541cf81d32b056b3cb79cdad24a7d5"
++checksum = "74e31a3ccaba362abf6bc2b461e569226cb2f37b161b44f7101b218f0232c955"
+ dependencies = [
+  "gdk",
+  "gio 0.18.4",
+@@ -1077,9 +1077,9 @@ dependencies = [
+ 
+ [[package]]
+ name = "libphosh-sys"
+-version = "0.0.4"
++version = "0.0.5"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "dd0a352ce928b225da90ba3f6fe75c378399b4d1a8700d4ded1f4922853d4760"
++checksum = "2839ca41063b7e44107cb27101eb48268ad035b20b7719d55cd5cae3f7f4dfa4"
+ dependencies = [
+  "gdk-pixbuf-sys",
+  "gdk-sys",
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -8,7 +8,7 @@ glob = "0.3.1"
+ greetd_ipc = { version = "0.10.0", features = ["sync-codec"] }
+ async-channel = "2.2.1"
+ anyhow = "1.0.82"
+-libphosh = "0.0.4"
++libphosh = "0.0.5"
+ clap = { version = "4.5.4", features = ["derive"] }
+ wayland-client = "0.31"
+ zbus = { version = "4", default-features = false, features = ["blocking", "async-io"] }
diff --git a/community/greetd-phrog/libphosh-0.43.patch b/community/greetd-phrog/libphosh-0.43.patch
deleted file mode 100644
index 1d2199984afbb8364d4abd8a28f95cc5c62a477a..0000000000000000000000000000000000000000
--- a/community/greetd-phrog/libphosh-0.43.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From 6755b434253503f811d6b287c3fdfc23626a8525 Mon Sep 17 00:00:00 2001
-From: fossdd <fossdd@pwned.life>
-Date: Wed, 27 Nov 2024 08:28:52 +0100
-Subject: [PATCH] Use libphosh-0.43
----
- libphosh-rs/Phosh-0.gir               | 4 ++--
- libphosh-rs/libphosh/sys/Cargo.toml   | 6 +++---
- libphosh-rs/libphosh/sys/build.rs     | 4 ++--
- libphosh-rs/libphosh/sys/src/lib.rs   | 2 +-
- libphosh-rs/libphosh/sys/tests/abi.rs | 2 +-
- 5 files changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/libphosh-rs/Phosh-0.gir b/libphosh-rs/Phosh-0.gir
-index 2b0ac4d..7025e9a 100644
---- a/libphosh-rs/Phosh-0.gir
-+++ b/libphosh-rs/Phosh-0.gir
-@@ -13,11 +13,11 @@ and/or use gtk-doc annotations.  -->
-   <include name="Gtk" version="3.0"/>
-   <include name="Handy" version="1"/>
-   <include name="NM" version="1.0"/>
--  <package name="libphosh-0.42"/>
-+  <package name="libphosh-0.43"/>
-   <c:include name="libphosh.h"/>
-   <namespace name="Phosh"
-              version="0"
--             shared-library="libphosh-0.42.so.0"
-+             shared-library="libphosh-0.43.so.0"
-              c:identifier-prefixes="Phosh"
-              c:symbol-prefixes="phosh">
-     <constant name="APP_AUTH_PROMPT_CHOICES_FORMAT"
-diff --git a/libphosh-rs/libphosh/sys/Cargo.toml b/libphosh-rs/libphosh/sys/Cargo.toml
-index d118d1c..aacf008 100644
---- a/libphosh-rs/libphosh/sys/Cargo.toml
-+++ b/libphosh-rs/libphosh/sys/Cargo.toml
-@@ -9,9 +9,9 @@ keywords = ["phosh", "gnome"]
- description = "FFI bindings for libphosh"
- license = "MIT"
- 
--[package.metadata.system-deps.libphosh_0_42]
--name = "libphosh-0.42"
--version = "0.42"
-+[package.metadata.system-deps.libphosh_0_43]
-+name = "libphosh-0.43"
-+version = "0.43"
- 
- [package.metadata.docs.rs]
- rustc-args = ["--cfg", "docsrs"]
-diff --git a/libphosh-rs/libphosh/sys/build.rs b/libphosh-rs/libphosh/sys/build.rs
-index 2691552..e6ffbcf 100644
---- a/libphosh-rs/libphosh/sys/build.rs
-+++ b/libphosh-rs/libphosh/sys/build.rs
-@@ -11,7 +11,7 @@ fn main() {} // prevent linking libraries to avoid documentation failure
- fn main() {
-     if let Ok(val) = std::env::var("CARGO_FEATURE_STATIC") {
-         if val == "1" {
--            std::env::set_var("SYSTEM_DEPS_LIBPHOSH_0_42_BUILD_INTERNAL", "always");
-+            std::env::set_var("SYSTEM_DEPS_LIBPHOSH_0_43_BUILD_INTERNAL", "always");
-         }
-     }
- 
-@@ -20,7 +20,7 @@ fn main() {
-     let out_dir = std::env::var("OUT_DIR").unwrap();
- 
-     if let Err(s) = system_deps::Config::new()
--        .add_build_internal("libphosh-0.42", move |name, version| {
-+        .add_build_internal("libphosh-0.43", move |name, version| {
-             // We're going to build and statically link phosh.
-             println!("cargo:rustc-link-lib=static={}", format!("phosh-{}", version));
- 
-diff --git a/libphosh-rs/libphosh/sys/src/lib.rs b/libphosh-rs/libphosh/sys/src/lib.rs
-index e3d58cd..83c55e4 100644
---- a/libphosh-rs/libphosh/sys/src/lib.rs
-+++ b/libphosh-rs/libphosh/sys/src/lib.rs
-@@ -4809,7 +4809,7 @@ impl ::std::fmt::Debug for PhoshWWan {
- }
- 
- 
--#[link(name = "phosh-0.42")]
-+#[link(name = "phosh-0.43")]
- extern "C" {
- 
-     //=========================================================================
-diff --git a/libphosh-rs/libphosh/sys/tests/abi.rs b/libphosh-rs/libphosh/sys/tests/abi.rs
-index d8bf02f..23330d9 100644
---- a/libphosh-rs/libphosh/sys/tests/abi.rs
-+++ b/libphosh-rs/libphosh/sys/tests/abi.rs
-@@ -15,7 +15,7 @@ use std::process::{Command, Stdio};
- use std::str;
- use tempfile::Builder;
- 
--static PACKAGES: &[&str] = &["libphosh-0.42"];
-+static PACKAGES: &[&str] = &["libphosh-0.43"];
- 
- #[derive(Clone, Debug)]
- struct Compiler {
--- 
-2.47.1
-