diff --git a/community/py3-pyldap/APKBUILD b/community/py3-pyldap/APKBUILD
index db744ec11a645a449d4c5b798a95b38ee164c5fe..60e4fb4934770204ef927442af363168b02fe444 100644
--- a/community/py3-pyldap/APKBUILD
+++ b/community/py3-pyldap/APKBUILD
@@ -2,13 +2,13 @@
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=py3-pyldap
 _pkgname=python-ldap
-pkgver=3.3.1
-pkgrel=1
+pkgver=3.4.0
+pkgrel=0
 pkgdesc="Python modules for implementing LDAP clients"
 url="https://github.com/python-ldap/python-ldap"
 arch="all"
-license="Python-2.0"
-depends="libldap py3-asn1 py3-asn1-modules"
+license="Python-2.0 AND MIT"
+depends="py3-asn1 py3-asn1-modules"
 checkdepends="
 	openldap
 	openldap-back-mdb
@@ -20,7 +20,6 @@ replaces="py-pyldap"
 provides="py-pyldap=$pkgver-r$pkgrel"
 source="https://github.com/$_pkgname/$_pkgname/archive/$_pkgname-$pkgver.tar.gz
 	fix-wrong-asserts-in-test_test_flags.patch
-	slapdtest-remove-config-dir-option.patch
 	fix-openldap-2.5-compat.patch
 	"
 builddir="$srcdir/$_pkgname-$_pkgname-$pkgver"
@@ -38,8 +37,7 @@ package() {
 }
 
 sha512sums="
-de13aefde8bc62e6bc8ad6a8206d3e448577f348146232b22b7597e7020818a52d706fae3da73a1d0284b7d0be8d28f90b39340a1071ea95e94a2d1aba86c589  python-ldap-3.3.1.tar.gz
+f83e2107f4b46929d6602df759d035389ee2781621eeabf6cc19d8d2fae4904bf4350a85512c6e3ffcd7651f3d45e650a83755cc58aebaaba83faf80d07b5b26  python-ldap-3.4.0.tar.gz
 d46b88e31bd0297c30db01161d77d287815ba269a02788e71a79cfd094dd6241c79934e6f97fe73a381def380d3f5045ec6b0ae6fd94052ff7d9bb5fecfcf905  fix-wrong-asserts-in-test_test_flags.patch
-afd36b795aa0ab49c0a632c30fc730737f326901f7d5c07fff2e0eb9a84db1585a6edec58462dcbde0d0866db4ccdab0e8bcdcd1ab4ef3506bd297878eae02d3  slapdtest-remove-config-dir-option.patch
 64dc48ab603856efdc2b71054fc1a5c880b9373ae0c7810c146efd7c48375119bc57dcc54bd34db7c241789fad82a327c08996fcf49f7effc20ecb1ca8962d84  fix-openldap-2.5-compat.patch
 "
diff --git a/community/py3-pyldap/slapdtest-remove-config-dir-option.patch b/community/py3-pyldap/slapdtest-remove-config-dir-option.patch
deleted file mode 100644
index 261d18dfd0cd901df37808074bca3076f9a01a0f..0000000000000000000000000000000000000000
--- a/community/py3-pyldap/slapdtest-remove-config-dir-option.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-This is ugly workaround for https://github.com/python-ldap/python-ldap/issues/422.
-See comment https://github.com/python-ldap/python-ldap/issues/422#issuecomment-958155173
-
---- a/Lib/slapdtest/_slapdtest.py
-+++ b/Lib/slapdtest/_slapdtest.py
-@@ -418,7 +418,7 @@
-         slapd_args = [
-             self.PATH_SLAPD,
-             '-f', self._slapd_conf,
--            '-F', self.testrundir,
-+            #'-F', self.testrundir,  XXX-Patched: workaround for https://github.com/python-ldap/python-ldap/issues/422
-             '-h', ' '.join(urls),
-         ]
-         if self._log.isEnabledFor(logging.DEBUG):