diff --git a/community/py3-lsp-server/APKBUILD b/community/py3-lsp-server/APKBUILD
index ffd5d1e4578eb2ca1d809ad2244e640d914933c3..40d8b8492a645d2ffc03f071560f0aebdf6e7149 100644
--- a/community/py3-lsp-server/APKBUILD
+++ b/community/py3-lsp-server/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Clayton Craft <clayton@craftyguy.net>
 # Maintainer: Clayton Craft <clayton@craftyguy.net>
 pkgname=py3-lsp-server
-pkgver=1.11.0
+pkgver=1.12.0
 pkgrel=0
 pkgdesc="python implementation of the language server protocol, fork of python-language-server"
 url="https://github.com/python-lsp/python-lsp-server"
@@ -42,7 +42,7 @@ checkdepends="
 	py3-yapf
 	"
 subpackages="$pkgname-pyc"
-source="https://files.pythonhosted.org/packages/source/p/python-lsp-server/python-lsp-server-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/python-lsp/python-lsp-server/archive/refs/tags/v$pkgver.tar.gz"
 builddir="$srcdir/python-lsp-server-$pkgver"
 
 build() {
@@ -59,6 +59,8 @@ check() {
 	k="$k and not test_symbols_all_scopes_with_jedi_environment"
 	# fails on riscv64
 	k="$k and not test_autoimport_code_actions_and_completions_for_notebook_document"
+	# requires deprecated pydocstyle
+	k="$k and not test_notebook_document__did_open and not test_notebook_document__did_change"
 	# deselect'ed tests are broken
 	# pydocstyle is no longer maintaned upstream
 	.testenv/bin/python3 -m pytest \
@@ -72,5 +74,5 @@ package() {
 }
 
 sha512sums="
-bd96850b822dc3c2e97d5ee38f25c9f7731dc68b31fedcc2d3e0ff373bc3ad8a989f1a4b85527477bbbc875e853d5513d8583bc3cdc22a3c0545716e68382093  python-lsp-server-1.11.0.tar.gz
+d394ca86cffe4296a15597316dca20a0d18cb28d506ea5dc6b56364d04c7353b79aeecec683d1d90cda0fa6c7a49dc42d9b7aa83b2a94f7e978e7b48fb4fc920  py3-lsp-server-1.12.0.tar.gz
 "