diff --git a/community/virt-manager/APKBUILD b/community/virt-manager/APKBUILD
index 55fafda4d215acfba69510d563a8742605fba643..5a1fc78b77b690160e548c084ba4819053125e3a 100644
--- a/community/virt-manager/APKBUILD
+++ b/community/virt-manager/APKBUILD
@@ -1,15 +1,29 @@
 # Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
 pkgname=virt-manager
-pkgver=4.0.0
+pkgver=4.1.0
 pkgrel=0
 pkgdesc="GUI for managing virtual machines"
 url="https://virt-manager.org/"
 arch="noarch !s390x !riscv64" # spice-gtk
 license="GPL-2.0-or-later"
-depends="python3 $pkgname-common spice-gtk vte3 py3-cairo gtk-vnc>=0.5.2-r2
-	gtksourceview4 qemu-img"
-_common_deps="libvirt-glib py3-libxml2 py3-libvirt py3-gobject3 py3-requests
-	libosinfo"
+depends="
+	python3
+	$pkgname-common
+	spice-gtk
+	vte3
+	py3-cairo
+	gtk-vnc>=0.5.2-r2
+	gtksourceview4
+	qemu-img
+	"
+_common_deps="
+	libvirt-glib
+	py3-libxml2
+	py3-libvirt
+	py3-gobject3
+	py3-requests
+	libosinfo
+	"
 makedepends="intltool glib py3-docutils py3-setuptools"
 checkdepends="
 	xorriso
@@ -19,24 +33,19 @@ checkdepends="
 	py3-libxml2
 	py3-pytest
 	py3-requests
-"
+	"
 subpackages="
 	$pkgname-doc
 	$pkgname-lang
 	$pkgname-common
 	virt-install:virt_install
-	$pkgname-bash-completion:bashcomp:noarch
+	$pkgname-bash-completion
 	"
-source="https://releases.pagure.org/virt-manager/virt-manager-$pkgver.tar.gz
-	drop-unfiltered-sgio.patch
+source="
+	https://releases.pagure.org/virt-manager/virt-manager-$pkgver.tar.gz
 	fix-latest-libvirt-xml-output.patch
 	"
 
-case "$CARCH" in
-	# py3-libvirt is not available
-	s390x) options="$options !check"
-esac
-
 # secfixes:
 #   2.2.1-r0:
 #     - CVE-2019-10183
@@ -61,7 +70,6 @@ check() {
 package() {
 	python3 setup.py --no-update-icon-cache --no-compile-schemas install --root "$pkgdir"
 	python3 -m compileall "$pkgdir/usr/share/virt-manager"
-	python3 -O -m compileall "$pkgdir/usr/share/virt-manager"
 }
 
 common() {
@@ -81,16 +89,7 @@ virt_install() {
 		"$subpkgdir"/usr/bin/
 }
 
-bashcomp() {
-	depends=""
-	pkgdesc="Bash completions for $pkgname"
-	install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
-	amove usr/share/bash-completion/completions
-}
-
 sha512sums="
-115dc3feb499bb2f1f6df537bffe150d23b9b568fe8047d43577a138ff9b9180b10259dde3476136cdc85750576da1104e81a8c2f5761b4f2a89852467761f81  virt-manager-4.0.0.tar.gz
-0d41a232758285e65dd245e83e9101635c0d7eb46ad351b1692d34b72ec2ce6bddae1eb8ca9897f476f74c8178da142215ce07e4933236440ca9369598498c85  drop-unfiltered-sgio.patch
+725cb5bcbaebaafae417f95deffb4243ccdad769668cba6e1235f4607e2b29dbd099d2a9a3885981158f53ea854dd71cc29ed9d7557b2791161c13d34f2ef883  virt-manager-4.1.0.tar.gz
 3106c7d3d91db6c7fa3208a13869c5a84bb636a261939acd3be0a59ce7196dfa6102ec97372d762d8143cef4a1d0ef1c37f4a107c3826c23ff2ed22c6d57f914  fix-latest-libvirt-xml-output.patch
 "
diff --git a/community/virt-manager/drop-unfiltered-sgio.patch b/community/virt-manager/drop-unfiltered-sgio.patch
deleted file mode 100644
index 5d998ba537fc33946461e3d4171e857901f6f9b4..0000000000000000000000000000000000000000
--- a/community/virt-manager/drop-unfiltered-sgio.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From c61074191d0d25ab7cd7830ef90a49a3caefcd09 Mon Sep 17 00:00:00 2001
-From: Cole Robinson <crobinso@redhat.com>
-Date: Wed, 13 Apr 2022 07:00:37 -0400
-Subject: [PATCH] tests: Drop usage of sgio=unfiltered
-
-libvirt 8.1.0+ rejects it, so it breaks the testsuite
-
-Fixes: #382
-
-Signed-off-by: Cole Robinson <crobinso@redhat.com>
----
- tests/data/testdriver/testdriver.xml    | 2 +-
- tests/data/xmlparse/change-disk-out.xml | 2 +-
- tests/test_xmlparse.py                  | 2 --
- 3 files changed, 2 insertions(+), 4 deletions(-)
-
-diff --git a/tests/data/testdriver/testdriver.xml b/tests/data/testdriver/testdriver.xml
-index 082ac095b..b213863d9 100644
---- a/tests/data/testdriver/testdriver.xml
-+++ b/tests/data/testdriver/testdriver.xml
-@@ -245,7 +245,7 @@ Foo bar baz &amp; yeah boii &lt; &gt; yeahfoo
-       <shareable/>
-     </disk>
- 
--    <disk type='block' device='lun' rawio='no' sgio='unfiltered'>
-+    <disk type='block' device='lun' rawio='no'>
-       <driver name='qemu' type='raw'/>
-       <source dev='/dev/szz'>
-         <reservations managed="yes"/>
-diff --git a/tests/data/xmlparse/change-disk-out.xml b/tests/data/xmlparse/change-disk-out.xml
-index 66a70395a..003750fb2 100644
---- a/tests/data/xmlparse/change-disk-out.xml
-+++ b/tests/data/xmlparse/change-disk-out.xml
-@@ -37,7 +37,7 @@
-     <disk type="file" device="floppy">
-       <target dev="fde" bus="fdc"/>
-     </disk>
--    <disk type="block" device="lun" sgio="unfiltered" rawio="yes">
-+    <disk type="block" device="lun">
-       <driver name="qemu" type="raw"/>
-       <source dev="/dev/sda"/>
-       <target dev="hdd" bus="scsi"/>
-diff --git a/tests/test_xmlparse.py b/tests/test_xmlparse.py
-index 15ca8f752..1bf0ebe58 100644
---- a/tests/test_xmlparse.py
-+++ b/tests/test_xmlparse.py
-@@ -314,8 +314,6 @@ def _get_disk(target):
-     check = _make_checker(disk)
-     check("type", "block")
-     check("device", "lun")
--    check("sgio", None, "unfiltered")
--    check("rawio", None, "yes")
- 
-     disk = _get_disk("sda")
-     check = _make_checker(disk)
-
-From 9ac94ef739687b9eeba37e8b28108269802db280 Mon Sep 17 00:00:00 2001
-From: Cole Robinson <crobinso@redhat.com>
-Date: Wed, 13 Apr 2022 08:16:47 -0400
-Subject: [PATCH] tests: Fix another sgio=filtered case
-
-Signed-off-by: Cole Robinson <crobinso@redhat.com>
----
- tests/data/cli/compare/virt-install-many-devices.xml | 2 +-
- tests/test_cli.py                                    | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/data/cli/compare/virt-install-many-devices.xml b/tests/data/cli/compare/virt-install-many-devices.xml
-index 4c0024225..db61f5117 100644
---- a/tests/data/cli/compare/virt-install-many-devices.xml
-+++ b/tests/data/cli/compare/virt-install-many-devices.xml
-@@ -249,7 +249,7 @@
-       <source file="/var/lib/libvirt/images/disk.qcow2"/>
-       <target dev="vdc" bus="virtio"/>
-     </disk>
--    <disk type="block" device="lun" sgio="unfiltered" rawio="yes">
-+    <disk type="block" device="lun" sgio="filtered" rawio="yes">
-       <driver name="qemu" type="raw"/>
-       <source dev="/pool-iscsi/diskvol1"/>
-       <target dev="sdab" bus="scsi"/>
-diff --git a/tests/test_cli.py b/tests/test_cli.py
-index 8b78a1a78..6a0df7870 100644
---- a/tests/test_cli.py
-+++ b/tests/test_cli.py
-@@ -579,7 +579,7 @@ def add_compare(self, cat, args, compbase, **kwargs):
- --disk source.file=%(NEWIMG1)s,sparse=false,size=.001,perms=ro,error_policy=enospace,detect_zeroes=unmap,address.type=drive,address.controller=0,address.target=2,address.unit=0
- --disk device=cdrom,bus=sata,read_bytes_sec=1,read_iops_sec=2,write_bytes_sec=5,write_iops_sec=6,driver.copy_on_read=on,geometry.cyls=16383,geometry.heads=16,geometry.secs=63,geometry.trans=lba,discard=ignore
- --disk size=1
----disk /pool-iscsi/diskvol1,total_bytes_sec=10,total_iops_sec=20,bus=scsi,device=lun,sgio=unfiltered,rawio=yes
-+--disk /pool-iscsi/diskvol1,total_bytes_sec=10,total_iops_sec=20,bus=scsi,device=lun,sgio=filtered,rawio=yes
- --disk /pool-dir/iso-vol,seclabel.model=dac,seclabel1.model=selinux,seclabel1.relabel=no,seclabel0.label=foo,bar,baz,iotune.read_bytes_sec=1,iotune.read_iops_sec=2,iotune.write_bytes_sec=5,iotune.write_iops_sec=6
- --disk /pool-dir/iso-vol,format=qcow2,startup_policy=optional,iotune.total_bytes_sec=10,iotune.total_iops_sec=20,
- --disk source_pool=pool-rbd-ceph,source_volume=some-rbd-vol,size=.1,driver_type=raw,driver_name=qemu