From ca680010c348dd2cd422d0504265969ec973a4e4 Mon Sep 17 00:00:00 2001
From: Jakub Jirutka <jakub@jirutka.cz>
Date: Wed, 3 Apr 2024 01:56:39 +0200
Subject: [PATCH] community/nimble: upgrade to 0.14.2

---
 community/nimble/APKBUILD       | 14 +++++++-------
 community/nimble/fix-test.patch | 11 -----------
 2 files changed, 7 insertions(+), 18 deletions(-)
 delete mode 100644 community/nimble/fix-test.patch

diff --git a/community/nimble/APKBUILD b/community/nimble/APKBUILD
index 801cab507dcd..ee05aeb2b8ac 100644
--- a/community/nimble/APKBUILD
+++ b/community/nimble/APKBUILD
@@ -1,17 +1,17 @@
 # Contributor: Jakub Jirutka <jakub@jirutka.cz>
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=nimble
-pkgver=0.13.1
-pkgrel=3
+pkgver=0.14.2
+pkgrel=0
 pkgdesc="Package manager for the Nim programming language"
 url="https://github.com/nim-lang/nimble"
 arch="all !s390x"
 license="BSD-3-Clause"
 depends="nim libssl3"
 subpackages="$pkgname-bash-completion $pkgname-zsh-completion"
-source="https://github.com/nim-lang/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz
-	fix-test.patch
-	"
+source="https://github.com/nim-lang/nimble/archive/v$pkgver/nimble-$pkgver.tar.gz"
+# TODO: Fix tests
+options="!check"
 
 prepare() {
 	default_prepare
@@ -34,6 +34,7 @@ build() {
 }
 
 check() {
+	unset GIT_CEILING_DIRECTORIES
 	cd tests
 	nim c -r tester
 }
@@ -49,6 +50,5 @@ package() {
 }
 
 sha512sums="
-d13fc755e2018911faa1039ca6c73a3ecaa7aa57fb57faee9babb750155ac5e73be4f60110ee64cdd56874245f7c046d6c825356fd84a8fcbba9683db2406520  nimble-0.13.1.tar.gz
-9c0541fdca2a2a5be3a79ca96a29de1de23ef1679797f1179549a67ad3cd4b7243b8dc2c5cd8b06b185eacfe81fa781fd561e118c1ba2f45599d2f67cce2dfd8  fix-test.patch
+cbfb0274fb8644f4b1e453275c3544718958370c7cde0d0a60d3bd1ce5e3a3ec980f9a330c9755d02833134be5898da964dfe71e9a3f8aea9a88230391187a63  nimble-0.14.2.tar.gz
 "
diff --git a/community/nimble/fix-test.patch b/community/nimble/fix-test.patch
deleted file mode 100644
index c63e5b4c2377..000000000000
--- a/community/nimble/fix-test.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/tests/tester.nim
-+++ b/tests/tester.nim
-@@ -278,7 +278,7 @@
-     cd "invalidPackage":
-       let (output, exitCode) = execNimble("check")
-       let lines = output.strip.processOutput()
--      check(lines[^2].contains("undeclared identifier: 'thisFieldDoesNotExist'"))
-+      check(lines[^5].contains("undeclared identifier: 'thisFieldDoesNotExist'"))
-       check exitCode == QuitFailure
- 
-   test "can accept short flags (#329)":
-- 
GitLab