diff --git a/community/htmlq/APKBUILD b/community/htmlq/APKBUILD
index 37002b57b360211d55399773b8a255fdc014031a..6b741c9acfbfdcf2f5d2f353818722282d06ed94 100644
--- a/community/htmlq/APKBUILD
+++ b/community/htmlq/APKBUILD
@@ -9,8 +9,7 @@ license="MIT"
 arch="all"
 makedepends="cargo cargo-auditable"
 source="https://github.com/mgdm/htmlq/archive/v$pkgver/htmlq-$pkgver.tar.gz
-	update-libc.patch
-	"
+	update-libc.patch"
 
 prepare() {
 	default_prepare
@@ -31,5 +30,5 @@ package() {
 
 sha512sums="
 3cbb53b66ca894b17c95487fe33a11587449af1b0acd5fa9e804b046e15fdd50a997b5367d0b00c20dce2587cfdf9d15b75cdd97007082928228a53b2f12fde7  htmlq-0.4.0.tar.gz
-df5f091b94629bc62372d48aa2c097a9d0ac80f829ee1cb1e2eb9bd7131a8851890b5701e71377d3fc609dbc31878307b59e808f5e46af8573b8fce285bb28f0  update-libc.patch
+74abd6b4d0e0dc1dff3dc638621cf0c2bd72100f84aace70786be307d77e218f85ccf298cb4e8a280409a4dc1f5fb0f59f01b925df79c14f263298e9c10a461a  update-libc.patch
 "
diff --git a/community/htmlq/update-libc.patch b/community/htmlq/update-libc.patch
index cc90e391a3a7c8c4d521b7afa89a24866edf2fd4..56e4806394125e0155dd65151cab8166e68b9819 100644
--- a/community/htmlq/update-libc.patch
+++ b/community/htmlq/update-libc.patch
@@ -1,7 +1,5 @@
-required to build properly on riscv64
-
 diff --git a/Cargo.lock b/Cargo.lock
-index c7efe9b..2110c7a 100644
+index c7efe9b..30394e3 100644
 --- a/Cargo.lock
 +++ b/Cargo.lock
 @@ -227,9 +227,9 @@ checksum = "e2abad23fbc42b3700f2f279844dc832adb2b2eb069b2df918f455c4e18cc646"
@@ -9,10 +7,10 @@ index c7efe9b..2110c7a 100644
  [[package]]
  name = "libc"
 -version = "0.2.101"
-+version = "0.2.149"
++version = "0.2.155"
  source = "registry+https://github.com/rust-lang/crates.io-index"
 -checksum = "3cb00336871be5ed2c8ed44b60ae9959dc5b9f08539422ed43f09e34ecaeba21"
-+checksum = "a08173bc88b7955d1b3145aa561539096c421ac8debde8cbc3612ec635fee29b"
++checksum = "97b3888a4aecf77e811145cadf6eef5901f4782c53886191b2f693f24761847c"
  
  [[package]]
  name = "log"