From c78dcd49b5882ecce2469ea97b315be0f73ad10c Mon Sep 17 00:00:00 2001
From: fossdd <fossdd@pwned.life>
Date: Wed, 19 Mar 2025 08:38:02 +0100
Subject: [PATCH] main/rust: upgrade to 1.85.1

https://github.com/rust-lang/rust/compare/1.85.0...1.85.1
---
 main/rust/APKBUILD                     |  8 ++---
 main/rust/downgrade-cc.patch           | 44 --------------------------
 main/rust/skip-submodule-updates.patch | 41 ------------------------
 3 files changed, 2 insertions(+), 91 deletions(-)
 delete mode 100644 main/rust/downgrade-cc.patch
 delete mode 100644 main/rust/skip-submodule-updates.patch

diff --git a/main/rust/APKBUILD b/main/rust/APKBUILD
index 7ada4a72aa70..967fc4ad2a1b 100644
--- a/main/rust/APKBUILD
+++ b/main/rust/APKBUILD
@@ -7,7 +7,7 @@
 # Contributor: omni <omni+alpine@hack.org>
 # Maintainer: team/rust <alpine@ptrcnull.me>
 pkgname=rust
-pkgver=1.85.0
+pkgver=1.85.1
 _llvmver=19
 _bootver=1.84.0
 pkgrel=0
@@ -104,8 +104,6 @@ source="https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.xz
 	need-ssp_nonshared.patch
 	no-export-ld-library-path.patch
 	system-wasm-ld.patch
-	downgrade-cc.patch
-	skip-submodule-updates.patch
 	check-rustc
 	"
 builddir="$srcdir/rustc-$pkgver-src"
@@ -543,7 +541,7 @@ _mv() {
 }
 
 sha512sums="
-3e9c933d1d9b6e5fb081837cf07eb1638b1a6b4fd1cb607dd860c5021ba7b521edbaf8ba0fa8f182f62178b72a3e1a3e6b26675e8fb6530871137852a074443c  rustc-1.85.0-src.tar.xz
+d61afb4f00d0c63eef132e10ca5369202064ecad8ab5bcf4fbd62e9a20b2bd71840b2a769dadcf43452fc0448865975c9de1c129752caa9928d2757027bacf7c  rustc-1.85.1-src.tar.xz
 9de9d7ad05584e3cafddedcac409a4605a1d67e82260220deb3efd965603ee3148062b081c0cd736e50d82daad3a723fb6a7493fdf4dddfe36288645425a7946  alpine-move-py-scripts-to-share.patch
 43fba7aa9d9491e4b46ad44061f12990ce0dc8858a330c0f35e1fd6a16c9fd09b2e51ca44ca9b60889540d7f047111129bd4ce8bcbfba068fb44fd581dee8d8b  alpine-target.patch
 aafaf76a3969666bbc5f8423cdbb6fdd62080298a5c9dd018cb157fcfa4a0ea9e7f9cf9313a70ad3f9453990ba3cbcae7b066c851a94b5608c0f0236dbd4937a  do-not-install-libunwind-source.patch
@@ -554,7 +552,5 @@ b283d31cc8d6559aa639d44f776e97c2a1e0f23c717b6784e549861b881555bd467fa6023180866a
 46d2eb72f78ec7dddf3e415cd037a18b8870776985be33ff120a329f6bb8f5d98a6573ee12dee31a37b08f0d2136ffb8a2a7685dac5c2302c4cb0c6f7b718012  need-ssp_nonshared.patch
 5f2aca58a64eaa24fbcf894f8e6532fad69ba25c9e3e915fa5045de179b72053c12c7f1e87213b8bcde61acb94fa35ec79e45429cf444a62b5de81dc4c239123  no-export-ld-library-path.patch
 0a6ac7d297a49973f420c8bb678def4ceb69f74d16c542d654d37d93d55e3349acf0143a99b9aa4c39c546a5fcc92be9fead6b94e668254cdb834048f54af75a  system-wasm-ld.patch
-19a3f3d16da7275589e131f64f76172b98ab316461015f11172f4c4fba4481965f5fa22a596d0a1b66ec12427ad95998823f82e9a3ad254887f5b1b6f65288ec  downgrade-cc.patch
-9e5ed87f903aa4de0914a32b30fdd1c6cf3a1b1281ddfde96b331a343973094a0e3283fb81ad5e47b6bcf730bacdaa8d9fabd9103b4e152d597d168c2b8fe1dd  skip-submodule-updates.patch
 c31fdfe8a9b3411576c75da46645cf0465b9053000a2ab49cf9b2f2733f679d6d33acbf236d67a20e14935d094a685453b7f1840180249f39d610fd0902c3125  check-rustc
 "
diff --git a/main/rust/downgrade-cc.patch b/main/rust/downgrade-cc.patch
deleted file mode 100644
index 2b48041b92e4..000000000000
--- a/main/rust/downgrade-cc.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Patch-Source: https://github.com/rust-lang/rust/pull/137460
----
-From e4ca11f87ffca8c63aa56d45b46e62b6acc58bd7 Mon Sep 17 00:00:00 2001
-From: onur-ozkan <work@onurozkan.dev>
-Date: Sun, 23 Feb 2025 08:23:51 +0300
-Subject: [PATCH] downgrade bootstrap `cc`
-
-Signed-off-by: onur-ozkan <work@onurozkan.dev>
----
- src/bootstrap/Cargo.lock | 4 ++--
- src/bootstrap/Cargo.toml | 4 +++-
- 2 files changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/src/bootstrap/Cargo.lock b/src/bootstrap/Cargo.lock
-index a47f3af60cbd5..890e64e2babbc 100644
---- a/src/bootstrap/Cargo.lock
-+++ b/src/bootstrap/Cargo.lock
-@@ -88,9 +88,9 @@ dependencies = [
- 
- [[package]]
- name = "cc"
--version = "1.2.0"
-+version = "1.1.22"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "1aeb932158bd710538c73702db6945cb68a8fb08c519e6e12706b94263b36db8"
-+checksum = "9540e661f81799159abee814118cc139a2004b3a3aa3ea37724a1b66530b90e0"
- dependencies = [
-  "shlex",
- ]
-diff --git a/src/bootstrap/Cargo.toml b/src/bootstrap/Cargo.toml
-index ed51862390d40..2c1d85b01e6af 100644
---- a/src/bootstrap/Cargo.toml
-+++ b/src/bootstrap/Cargo.toml
-@@ -37,7 +37,9 @@ test = false
- # Most of the time updating these dependencies requires modifications to the
- # bootstrap codebase(e.g., https://github.com/rust-lang/rust/issues/124565);
- # otherwise, some targets will fail. That's why these dependencies are explicitly pinned.
--cc = "=1.2.0"
-+#
-+# Do not upgrade this crate unless https://github.com/rust-lang/cc-rs/issues/1317 is fixed.
-+cc = "=1.1.22"
- cmake = "=0.1.48"
- 
- build_helper = { path = "../build_helper" }
diff --git a/main/rust/skip-submodule-updates.patch b/main/rust/skip-submodule-updates.patch
deleted file mode 100644
index 746378137bc9..000000000000
--- a/main/rust/skip-submodule-updates.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Patch-Source: https://github.com/rust-lang/rust/pull/137338
----
-From d2203ad59c67a6acb2968ea77e1e9dea5530e518 Mon Sep 17 00:00:00 2001
-From: onur-ozkan <work@onurozkan.dev>
-Date: Thu, 20 Feb 2025 22:48:39 +0300
-Subject: [PATCH] skip submodule updating logics on tarballs
-
-Signed-off-by: onur-ozkan <work@onurozkan.dev>
----
- src/bootstrap/src/core/config/config.rs | 2 +-
- src/bootstrap/src/lib.rs                | 4 ++++
- 2 files changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/src/bootstrap/src/core/config/config.rs b/src/bootstrap/src/core/config/config.rs
-index 64a510240f837..172b8d787640d 100644
---- a/src/bootstrap/src/core/config/config.rs
-+++ b/src/bootstrap/src/core/config/config.rs
-@@ -2767,7 +2767,7 @@ impl Config {
-         ),
-     )]
-     pub(crate) fn update_submodule(&self, relative_path: &str) {
--        if !self.submodules() {
-+        if self.rust_info.is_from_tarball() || !self.submodules() {
-             return;
-         }
- 
-diff --git a/src/bootstrap/src/lib.rs b/src/bootstrap/src/lib.rs
-index dfaf0418d9a2b..a0934a8d55663 100644
---- a/src/bootstrap/src/lib.rs
-+++ b/src/bootstrap/src/lib.rs
-@@ -481,6 +481,10 @@ impl Build {
-         ),
-     )]
-     pub fn require_submodule(&self, submodule: &str, err_hint: Option<&str>) {
-+        if self.rust_info().is_from_tarball() {
-+            return;
-+        }
-+
-         // When testing bootstrap itself, it is much faster to ignore
-         // submodules. Almost all Steps work fine without their submodules.
-         if cfg!(test) && !self.config.submodules() {
-- 
GitLab