diff --git a/community/py3-sqlalchemy/APKBUILD b/community/py3-sqlalchemy/APKBUILD
index df15a8a781b47ea29301f373891eb0c8b5d77301..1fe66930c471392856a81801688e9adc478350ea 100644
--- a/community/py3-sqlalchemy/APKBUILD
+++ b/community/py3-sqlalchemy/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Steven Guikal <void@fluix.one>
 # Maintainer: Steven Guikal <void@fluix.one>
 pkgname=py3-sqlalchemy
-pkgver=2.0.34
+pkgver=2.0.38
 pkgrel=0
 pkgdesc="object relational mapper for Python"
 url="https://pypi.org/project/SQLAlchemy"
@@ -52,7 +52,8 @@ build() {
 check() {
 	python3 -m venv --clear --without-pip --system-site-packages .testenv
 	.testenv/bin/python3 -m installer .dist/*.whl
-	.testenv/bin/python3 -m pytest -n auto
+	# mypy plugin tests fail with mypy 1.14.x
+	.testenv/bin/python3 -m pytest -n auto -m "not mypy"
 }
 
 package() {
@@ -61,5 +62,5 @@ package() {
 }
 
 sha512sums="
-fd585ed9a78a86deaab1f84b5ff29f37120c08f3c8c93566786b73d74ce67f1f71097e43d42b0999be1aca493ae1c55d5a0c2d49386b65dcca566c036401232b  sqlalchemy-2.0.34.tar.gz
+244df15b30a2d585aa9cb1d89b7460b1e75871a5e41579a23743bbfe40ece9c5c24308e317ccb7686ba7599a2e02a61f61077da6e1ab8567e4e31d61d4d77380  sqlalchemy-2.0.38.tar.gz
 "