From c7668467085bc110f97aded3f8293e85db1fb873 Mon Sep 17 00:00:00 2001
From: prspkt <prspkt@protonmail.com>
Date: Tue, 12 Apr 2022 21:01:36 +0300
Subject: [PATCH] testing/labwc: fix version output

 - Print snapshot version from package instead of git branch, commit
   hash.
---
 testing/labwc/APKBUILD                        |  6 ++++--
 testing/labwc/remove-aports-git-version.patch | 16 ++++++++++++++++
 2 files changed, 20 insertions(+), 2 deletions(-)
 create mode 100644 testing/labwc/remove-aports-git-version.patch

diff --git a/testing/labwc/APKBUILD b/testing/labwc/APKBUILD
index 8ac39b08b2e0..d312dc57a64b 100644
--- a/testing/labwc/APKBUILD
+++ b/testing/labwc/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
 pkgname=labwc
 pkgver=0.5.1
-pkgrel=0
+pkgrel=1
 pkgdesc="Wayland stacking compositor"
 url="https://github.com/labwc/labwc"
 arch="all"
@@ -19,7 +19,8 @@ makedepends="
 	wlroots-dev
 	"
 subpackages="$pkgname-doc"
-source="https://github.com/labwc/labwc/archive/$pkgver/labwc-$pkgver.tar.gz"
+source="https://github.com/labwc/labwc/archive/$pkgver/labwc-$pkgver.tar.gz
+	remove-aports-git-version.patch"
 
 build() {
 	abuild-meson . output -Dman-pages=enabled
@@ -36,4 +37,5 @@ package() {
 
 sha512sums="
 bb73bd97dd8f92701abbb415da70dc51947651b993076a3ecb50eee4289798a5008758077bc08c94554c38caf910d164bbd18f3a6ec7dd4348a082564ac85eb3  labwc-0.5.1.tar.gz
+494e9fa10db3cd1c610378ba4657d1a8ec0ebe8fc4efd549e5df4675c460cb09def0c10463b5a6f16de41f70a2f60c0ee8e934558caa4c16a80d19177686dc4d  remove-aports-git-version.patch
 "
diff --git a/testing/labwc/remove-aports-git-version.patch b/testing/labwc/remove-aports-git-version.patch
new file mode 100644
index 000000000000..8c57ceaf2830
--- /dev/null
+++ b/testing/labwc/remove-aports-git-version.patch
@@ -0,0 +1,16 @@
+--- a/meson.build
++++ b/meson.build
+@@ -28,13 +28,6 @@
+ )
+
+ version='"@0@"'.format(meson.project_version())
+-git = find_program('git', native: true, required: false)
+-if git.found()
+-  git_commit = run_command([git, 'describe', '--dirty'])
+-  if git_commit.returncode() == 0
+-    version = '"@0@"'.format(git_commit.stdout().strip())
+-  endif
+-endif
+ add_project_arguments('-DLABWC_VERSION=@0@'.format(version), language: 'c')
+
+ wlroots_version = ['>=0.15.0', '<0.16.0']
-- 
GitLab