diff --git a/community/texmf-dist/APKBUILD b/community/texmf-dist/APKBUILD
index 4b53c9f1b6c6855a6ea6ac31135e2c398e46197e..5b10b82cb85b26fe5750f2f9d86144a704ddbd41 100644
--- a/community/texmf-dist/APKBUILD
+++ b/community/texmf-dist/APKBUILD
@@ -3,7 +3,7 @@
 pkgname=texmf-dist
 pkgver=2024.0
 _release=20240312
-pkgrel=0
+pkgrel=1
 pkgdesc="TeX Live texmf core distribution"
 url="https://tug.org/texlive/"
 # texlive
@@ -19,9 +19,50 @@ makedepends="
 	gawk
 	"
 subpackages="
-	$pkgname-full
-	$pkgname-lang
-	$pkgname-most
+	texmf-dist-lang
+	texmf-dist-full
+	texmf-dist-most
+
+	texmf-dist-bibtexextra:_subpkg
+	texmf-dist-binextra:_subpkg
+	texmf-dist-context:_subpkg
+	texmf-dist-fontsextra:_subpkg
+	texmf-dist-fontsrecommended:_subpkg
+	texmf-dist-fontutils:_subpkg
+	texmf-dist-formatsextra:_subpkg
+	texmf-dist-games:_subpkg
+	texmf-dist-humanities:_subpkg
+	texmf-dist-langarabic:_subpkg
+	texmf-dist-langchinese:_subpkg
+	texmf-dist-langcjk:_subpkg
+	texmf-dist-langcyrillic:_subpkg
+	texmf-dist-langczechslovak:_subpkg
+	texmf-dist-langenglish:_subpkg
+	texmf-dist-langeuropean:_subpkg
+	texmf-dist-langfrench:_subpkg
+	texmf-dist-langgerman:_subpkg
+	texmf-dist-langgreek:_subpkg
+	texmf-dist-langitalian:_subpkg
+	texmf-dist-langjapanese:_subpkg
+	texmf-dist-langkorean:_subpkg
+	texmf-dist-langother:_subpkg
+	texmf-dist-langpolish:_subpkg
+	texmf-dist-langportuguese:_subpkg
+	texmf-dist-langspanish:_subpkg
+	texmf-dist-latex:_subpkg
+	texmf-dist-latexextra:_subpkg
+	texmf-dist-latexrecommended:_subpkg
+	texmf-dist-luatex:_subpkg
+	texmf-dist-mathscience:_subpkg
+	texmf-dist-metapost:_subpkg
+	texmf-dist-music:_subpkg
+	texmf-dist-pictures:_subpkg
+	texmf-dist-plaingeneric:_subpkg
+	texmf-dist-pstricks:_subpkg
+	texmf-dist-publishers:_subpkg
+	texmf-dist-texworks:_subpkg
+	texmf-dist-wintools:_subpkg
+	texmf-dist-xetex:_subpkg
 	"
 source="
 	https://ftp.tu-chemnitz.de/pub/tug/historic/systems/texlive/${_release:0:4}/texlive-$_release-texmf.tar.xz
@@ -32,8 +73,6 @@ source="
 	0002-fix-newtt-map.patch
 	"
 builddir="$srcdir/texlive-$_release-texmf"
-# This is a data only package; no unit tests to run
-options="!check"
 
 _tlpdb="$srcdir/texlive-$pkgver.tlpdb"
 
@@ -134,19 +173,33 @@ build() {
 	return 0
 }
 
-package() {
-	# populate the subpackages based on the collections in the tlpdb
+check() {
+	# there are no unit tests, but we check if the subpackages do still
+	# match the list of collections in the tlpdb
 	local collections
 	collections="$(_tlpdb_get_collections)"
 
 	for collection in $collections; do
-		# the basic collection goes into the root package, all others will be
-		# subpackages
-		if [ "$collection" != "basic" ]; then
-			subpackages="$subpackages texmf-dist-$collection:_subpkg"
-		fi
+		case "$collection" in
+		basic)
+			# no subpackage for basic, the basic collection goes into the root
+			# package instead
+			;;
+		*)
+			case "$subpackages" in
+			*"texmf-dist-$collection"*)
+				# collection in subpackages, everything fine
+				;;
+			*)
+				echo "subpackage \"texmf-dist-$collection\" missing"
+				return 1
+			esac
+			;;
+		esac
 	done
+}
 
+package() {
 	_pack_collection "basic" "$pkgdir"
 
 	# install tlpkg parts needed for texconfig