From c6a18dc3edc2947fe1b83a050db873e8646cea24 Mon Sep 17 00:00:00 2001
From: ptrcnull <git@ptrcnull.me>
Date: Thu, 8 Aug 2024 20:13:20 +0200
Subject: [PATCH] testing/py3-firmata: build with gpep517

---
 testing/py3-firmata/APKBUILD | 19 ++++++++++++-------
 1 file changed, 12 insertions(+), 7 deletions(-)

diff --git a/testing/py3-firmata/APKBUILD b/testing/py3-firmata/APKBUILD
index 4f6f265de38e..d3579b419858 100644
--- a/testing/py3-firmata/APKBUILD
+++ b/testing/py3-firmata/APKBUILD
@@ -3,32 +3,37 @@
 pkgname=py3-firmata
 _pkgname=pyFirmata
 pkgver=1.0.3
-pkgrel=9
+pkgrel=10
 pkgdesc="Python interface for the Firmata procotol"
 url="https://github.com/tino/pyFirmata"
 arch="noarch"
 license="MIT"
 depends="python3 py3-pyserial"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517"
 subpackages="$pkgname-pyc"
 source="$_pkgname-$pkgver.tar.gz::https://github.com/tino/pyFirmata/archive/$pkgver.tar.gz
 	py311.patch
 	"
 builddir="$srcdir/$_pkgname-$pkgver"
 
-replaces=py-firmata # Backwards compatibility
-provides=py-firmata=$pkgver-r$pkgrel # Backwards compatibility
+replaces="py-firmata" # Backwards compatibility
+provides="py-firmata=$pkgver-r$pkgrel" # Backwards compatibility
 
 build() {
-	python3 setup.py build
+	gpep517 build-wheel \
+		--wheel-dir .dist \
+		--output-fd 3 3>&1 >&2
 }
 
 check() {
-	python3 setup.py test
+	python3 -m venv --clear --without-pip --system-site-packages .testenv
+	gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
+	.testenv/bin/python3 -m unittest discover
 }
 
 package() {
-	python3 setup.py install --skip-build --root="$pkgdir"
+	gpep517 install-wheel --destdir "$pkgdir" \
+		.dist/*.whl
 }
 
 sha512sums="
-- 
GitLab