diff --git a/main/unionfs-fuse/0001-include-asm-ioctl.h-for-_IOC_SIZE.patch b/main/unionfs-fuse/0001-include-asm-ioctl.h-for-_IOC_SIZE.patch
index 3ad15190a7c26c1ea1507cdd1a60268f85643268..8a642810d7e279ac325bbf5bcd117a8d356013ad 100644
--- a/main/unionfs-fuse/0001-include-asm-ioctl.h-for-_IOC_SIZE.patch
+++ b/main/unionfs-fuse/0001-include-asm-ioctl.h-for-_IOC_SIZE.patch
@@ -1,24 +1,12 @@
-From f64b094eba93b042a1ed5964db01867bc5610906 Mon Sep 17 00:00:00 2001
-From: Carlo Landmeter <clandmeter@gmail.com>
-Date: Tue, 10 Nov 2015 11:39:40 +0100
-Subject: [PATCH] include asm/ioctl.h for _IOC_SIZE
-
----
- src/unionfs.c | 1 +
- 1 file changed, 1 insertion(+)
-
 diff --git a/src/unionfs.c b/src/unionfs.c
-index 69b45e5..c4e8dac 100644
+index 5aed5ce..9236c57 100644
 --- a/src/unionfs.c
 +++ b/src/unionfs.c
-@@ -32,6 +32,7 @@
- #include <sys/types.h>
+@@ -33,6 +33,7 @@
  #include <sys/time.h>
  #include <inttypes.h>
+ #include <sys/ioctl.h>
 +#include <asm/ioctl.h>
  
  #ifdef linux
  	#include <sys/vfs.h>
--- 
-2.6.3
-
diff --git a/main/unionfs-fuse/APKBUILD b/main/unionfs-fuse/APKBUILD
index 2db845f8194de7cbbaf0ebd09ee4bb53f0cab0b4..114177a62554d1b668d1b86bbea23096e2be6675 100644
--- a/main/unionfs-fuse/APKBUILD
+++ b/main/unionfs-fuse/APKBUILD
@@ -1,42 +1,24 @@
 # Maintainer: Michael Zhou <zhoumichaely@gmail.com>
 pkgname=unionfs-fuse
-pkgver=1.0
+pkgver=2.0
 pkgrel=0
 pkgdesc="Union Filesystem in Userspace"
-url="https://podgorny.cz/moin/UnionFsFuse"
+url="https://github.com/rpodgorny/unionfs-fuse"
 arch="all"
-license="BSD"
-depends=""
+license="BSD-3-Clause"
 makedepends="fuse-dev linux-headers"
 subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/rpodgorny/unionfs-fuse/archive/v${pkgver}.tar.gz
-	0001-include-asm-ioctl.h-for-_IOC_SIZE.patch"
-
-_builddir="${srcdir}"/$pkgname-$pkgver
-
-prepare() {
-        cd "$_builddir"
-        for i in $source; do
-                case $i in
-                *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
-                esac
-        done
-}
+source="$pkgname-$pkgver.tar.gz::https://github.com/rpodgorny/unionfs-fuse/archive/v$pkgver.tar.gz
+	0001-include-asm-ioctl.h-for-_IOC_SIZE.patch
+	"
 
 build() {
-	cd "$_builddir"
-	make || return 1
+	make
 }
 
 package() {
-	cd "$_builddir"
-	mkdir -p "$pkgdir"/usr/share/man/man8/
-	make DESTDIR="$pkgdir" PREFIX=/usr install || return 1
+	make DESTDIR="$pkgdir" PREFIX=/usr install
 }
 
-md5sums="598590fb452129c413572ed79824c68a  unionfs-fuse-1.0.tar.gz
-437f961b03f7f6936448586b9ff8b7de  0001-include-asm-ioctl.h-for-_IOC_SIZE.patch"
-sha256sums="2ee80bd0634a61adb2159212e155d607a0a82ad659214ae6edb3530396cccc09  unionfs-fuse-1.0.tar.gz
-c8526f80448f344fba0100e5510793b6de985b24a8b526d9a6803bcd713d9de2  0001-include-asm-ioctl.h-for-_IOC_SIZE.patch"
-sha512sums="805151acaeae8526fba430701a1690f6eb0ad8331a9e730095ee538dc2b148d02fe996a63e8a7f6471d1ef622cc5c03d82bd2b2faad1ebe3b614ec343c2f55de  unionfs-fuse-1.0.tar.gz
-fa8d87a33c6971fff13545766c803cbe6960db068edd6e1f6479d76e17f60fce1b6e67a6045878a2f2cffbe9aa3064522f2e88e395d7713627ea12f24a02e346  0001-include-asm-ioctl.h-for-_IOC_SIZE.patch"
+sha512sums="5b60204632f498931fff7671cc9f40b1800d34cb8c0d0de0773626e2653eb0a36647566c92c1d0cf79543e01b934602ef5603a06508407f352e48ef27a7ee758  unionfs-fuse-2.0.tar.gz
+a3dedebb86446a0b992c18d4cc27f223eac554e9688c0cfd6e4806302cb6afce3f691a1cabd540626cdbd7ee94171d6c39b361292c12f2ce43d885d04cf65412  0001-include-asm-ioctl.h-for-_IOC_SIZE.patch"