diff --git a/community/salt/APKBUILD b/community/salt/APKBUILD
index 168ddb0509e0459ab4ae422f11735ce722cb5b55..9999b5be4b6dfa7ddf90a8d904a6b0006142e2e0 100644
--- a/community/salt/APKBUILD
+++ b/community/salt/APKBUILD
@@ -4,7 +4,7 @@
 # Maintainer: Will Sinatra <wpsinatra@gmail.com>
 pkgname=salt
 pkgver=3007.1
-pkgrel=0
+pkgrel=1
 pkgdesc="parallel remote execution system"
 url="https://github.com/saltstack/salt"
 arch="noarch"
@@ -45,6 +45,7 @@ source="https://pypi.io/packages/source/s/salt/salt-$pkgver.tar.gz
 	salt-syndic.confd
 	salt-syndic.initd
 	fix-cryptodome-dependency.patch
+	fix-urllib.parse-module.patch
 	"
 options="!check" # depends on pytestsalt
 
@@ -195,4 +196,5 @@ cfbbeb8023a383e7c42d84e3346edfd068c9ec7650c4ddc3caa38534da325a67497e1f06ca02cc1f
 bafc6ea10cdafd0aef868feb35aecbe4ae6a7dff0ae42862bded85715ad763eb89e1ed27437866a7e5f2b9f7064e3c2a3fb59814487744ba4227238d95cf3818  salt-syndic.confd
 d71133e834685304e0167554035ebbc861252f972bbe981cc71e45b70f15d94a28a02a369463c9a641372919689f96b62a0408b14f824ad986d536e52b1e5ec0  salt-syndic.initd
 7df577b4a7befc6a37644cbe3e909df29f626f9ccc84d05245c5d2b6a4daeb3ad6bb95b9b3a82de70d50ddc27d15956b016c44c8ad9f878c760d388da86cacbe  fix-cryptodome-dependency.patch
+d606c572ee92846a6b37cee6be961e2d29b2398f899a93fccdf822226e956cd1c11d397f1e34929658441598d489682a08c28dfc1fc941047f45af3e8edeacbd  fix-urllib.parse-module.patch
 "
diff --git a/community/salt/fix-urllib.parse-module.patch b/community/salt/fix-urllib.parse-module.patch
new file mode 100644
index 0000000000000000000000000000000000000000..de65fc00f8b4784dfdf99b39bd1f64a1a43388ce
--- /dev/null
+++ b/community/salt/fix-urllib.parse-module.patch
@@ -0,0 +1,49 @@
+From 187f1f6f3bf6e5f8da4f7029368ddd0967711ba9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Marek=20Marczykowski-G=C3=B3recki?=
+ <marmarek@invisiblethingslab.com>
+Date: Wed, 18 Sep 2024 04:54:24 +0200
+Subject: [PATCH] Fix Python3.13 compatibility regarding urllib.parse module
+
+Python 3.13 fixed handling relative paths in urllib.parse module.
+Specifically, relative file URL is now constructed as file:path instead
+of converting it to absolute file:///path. This breaks
+salt.utils.url.create which expects file:/// specifically. The mismatch
+results in for example changing salt://top.sls into salt://.sls and thus
+not finding the top file.
+
+Fix this by handling both prefixes.
+
+Relevant python change: https://github.com/python/cpython/issues/85110
+Fixes: #66898
+---
+ changelog/66898.fixed.md | 1 +
+ salt/utils/url.py        | 5 ++++-
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+ create mode 100644 changelog/66898.fixed.md
+
+diff --git a/changelog/66898.fixed.md b/changelog/66898.fixed.md
+new file mode 100644
+index 0000000000..2549d5e00e
+--- /dev/null
++++ b/changelog/66898.fixed.md
+@@ -0,0 +1 @@
++Fixed Python 3.13 compatibility regarding urllib.parse module
+diff --git a/salt/utils/url.py b/salt/utils/url.py
+index 478d8e911c..6d7ea37e6d 100644
+--- a/salt/utils/url.py
++++ b/salt/utils/url.py
+@@ -47,7 +47,10 @@ def create(path, saltenv=None):
+ 
+     query = f"saltenv={saltenv}" if saltenv else ""
+     url = salt.utils.data.decode(urlunparse(("file", "", path, "", query, "")))
+-    return "salt://{}".format(url[len("file:///") :])
++    # urlunparse changed behavior in Python 3.13
++    if url.startswith("file:///"):
++        return "salt://{}".format(url[len("file:///") :])
++    return "salt://{}".format(url[len("file:") :])
+ 
+ 
+ def is_escaped(url):
+-- 
+2.46.0
+