diff --git a/community/gitstatus/APKBUILD b/community/gitstatus/APKBUILD
index 7972c924fcf5885e321b7121b087f2fab31bc39c..946297e479e2f512fb5db7606cc1a0dbbd1dc521 100644
--- a/community/gitstatus/APKBUILD
+++ b/community/gitstatus/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=gitstatus
 pkgver=1.5.4
-pkgrel=0
+pkgrel=1
 pkgdesc="Git status for Bash and Zsh prompt"
 url="https://github.com/romkatv/gitstatus"
 arch="all"
@@ -11,6 +11,7 @@ makedepends="
 	cmake
 	http-parser-dev
 	pcre-dev
+	samurai
 	zlib-dev
 	zsh
 	"
@@ -63,7 +64,7 @@ build() {
 	# 1st group of flags is copied from the gitstatus' build script.
 	# 2nd group is also present in the build script, but they were changed
 	# in favour of shared dependencies.
-	cmake -B build \
+	cmake -B build -G Ninja \
 		-DCMAKE_BUILD_TYPE=None \
 		-DZERO_NSEC=ON \
 		-DTHREADSAFE=ON \