diff --git a/community/skopeo/APKBUILD b/community/skopeo/APKBUILD
index 768052f9b72eac6c3a8b2af0d1268c40d5c74546..1df33e59b878ae6585f5ea8095e32c045668b678 100644
--- a/community/skopeo/APKBUILD
+++ b/community/skopeo/APKBUILD
@@ -3,6 +3,8 @@
 pkgname=skopeo
 pkgver=1.6.1
 pkgrel=1
+# set this to the gitrev of the version
+_gitrev=49084d2cd8c9f8e7b38ba8405d61e701d5381bc0
 pkgdesc="Work with remote images registries - retrieving information, images, signing content"
 url="https://github.com/containers/skopeo"
 license="Apache-2.0"
@@ -31,7 +33,7 @@ source="https://github.com/containers/skopeo/archive/v$pkgver/skopeo-$pkgver.tar
 export GOPATH="$srcdir"
 
 build() {
-	go build -o bin/$pkgname ./cmd/$pkgname
+	make GIT_COMMIT=$_gitrev all
 }
 
 check() {