diff --git a/community/cgmanager/APKBUILD b/community/cgmanager/APKBUILD
index 8fa7e42eb68c184f3a6f957c800d84c2fd4ed6f6..8b43cfcf04985c6947ed1aeb293b919417be7d14 100644
--- a/community/cgmanager/APKBUILD
+++ b/community/cgmanager/APKBUILD
@@ -14,6 +14,11 @@ source="https://linuxcontainers.org/downloads/cgmanager/cgmanager-$pkgver.tar.gz
 	cgmanager.initd
 	cgproxy.initd"
 
+prepare(){
+	default_prepare
+	update_config_sub
+}
+
 build() {
 	./configure \
 		--build=$CBUILD \
diff --git a/community/gparted/APKBUILD b/community/gparted/APKBUILD
index 3088e12650eddc9b078c8be46c59c765afe73e2f..d3608a134ce9735df86cf0c60c4f23c929ec8f60 100644
--- a/community/gparted/APKBUILD
+++ b/community/gparted/APKBUILD
@@ -19,6 +19,11 @@ makedepends="
 subpackages="$pkgname-doc $pkgname-lang"
 source="https://downloads.sourceforge.net/project/gparted/gparted/gparted-$pkgver/gparted-$pkgver.tar.gz"
 
+prepare(){
+	default_prepare
+	update_config_sub
+}
+
 build() {
 	./configure \
 		--build=$CBUILD \
diff --git a/community/libcdio/APKBUILD b/community/libcdio/APKBUILD
index 606dce59dbfdfe23251193f6381a754d6e3b6433..d627e38aa062a9a2f9d6c988bb9913f9d181d277 100644
--- a/community/libcdio/APKBUILD
+++ b/community/libcdio/APKBUILD
@@ -15,6 +15,11 @@ source="https://ftp.gnu.org/gnu/libcdio/libcdio-$pkgver.tar.bz2
 	format-security.patch
 	"
 
+prepare(){
+	default_prepare
+	update_config_sub
+}
+
 build() {
 	./configure \
 		--build=$CBUILD \
diff --git a/community/libdvdnav/APKBUILD b/community/libdvdnav/APKBUILD
index 812d22afa4944eae8ffbf164271af6bb8b739948..5630175a27d6d26bd546c75c908c2c7a5bcfe947 100644
--- a/community/libdvdnav/APKBUILD
+++ b/community/libdvdnav/APKBUILD
@@ -11,6 +11,11 @@ makedepends="libdvdread-dev>=5.0.3"
 subpackages="$pkgname-dev $pkgname-doc"
 source="https://download.videolan.org/pub/videolan/libdvdnav/$pkgver/libdvdnav-$pkgver.tar.bz2"
 
+prepare(){
+	default_prepare
+	update_config_sub
+}
+
 build() {
 	./configure \
 		--build=$CBUILD \
diff --git a/community/libraw/APKBUILD b/community/libraw/APKBUILD
index b60ec66e30cc3ae404574a164730e6208c33192b..196e3fcc86ae1af7b26cf78b8baa2ebd6837e01c 100644
--- a/community/libraw/APKBUILD
+++ b/community/libraw/APKBUILD
@@ -39,6 +39,11 @@ options="!check" # no tests
 #     - CVE-2017-13735
 #     - CVE-2017-14265
 
+prepare(){
+	default_prepare
+	update_config_sub
+}
+
 build() {
 	# trading size for more speed
 	CFLAGS="$CFLAGS -O3 -flto=auto" \
diff --git a/community/lsscsi/APKBUILD b/community/lsscsi/APKBUILD
index c24bf2bc23ab3047891b5ba53648af4b67d30300..63da16f29060508b113f49ed672e371b0eb0ac8e 100644
--- a/community/lsscsi/APKBUILD
+++ b/community/lsscsi/APKBUILD
@@ -10,6 +10,11 @@ makedepends="linux-headers"
 subpackages="$pkgname-doc"
 source="http://sg.danny.cz/scsi/lsscsi-$pkgver.tar.xz"
 
+prepare(){
+	default_prepare
+	update_config_sub
+}
+
 build() {
 	./configure \
 		--build=$CBUILD \
diff --git a/community/mate-icon-theme/APKBUILD b/community/mate-icon-theme/APKBUILD
index 615400c06c4413a4fd75faeb93a1ab00d63c053e..cb2aa4733f11175209c763b4c5e11e08b53571f2 100644
--- a/community/mate-icon-theme/APKBUILD
+++ b/community/mate-icon-theme/APKBUILD
@@ -11,6 +11,11 @@ depends="mate-common"
 makedepends="icon-naming-utils intltool"
 source="https://pub.mate-desktop.org/releases/${pkgver%.*}/mate-icon-theme-$pkgver.tar.xz"
 
+prepare(){
+	default_prepare
+	update_config_sub
+}
+
 build() {
 	DATADIRNAME=share ./configure \
 		--build=$CBUILD \
diff --git a/community/potrace/APKBUILD b/community/potrace/APKBUILD
index c05faac9bc97df83152ed4614f65bf4ecaeec300..2958e91a33b3649692a3c5a1d45f18503bf112f9 100644
--- a/community/potrace/APKBUILD
+++ b/community/potrace/APKBUILD
@@ -12,6 +12,11 @@ makedepends="$depends_dev"
 subpackages="$pkgname-dev $pkgname-doc"
 source="https://potrace.sourceforge.net/download/$pkgver/$pkgname-$pkgver.tar.gz"
 
+prepare(){
+        default_prepare
+        update_config_sub
+}
+
 build() {
 	./configure \
 		--build=$CBUILD \