diff --git a/community/asuran-cli/APKBUILD b/community/asuran-cli/APKBUILD
index 8cd09c6bb5d99df4429e468b5114e2b3871b3242..3f257ff45d8627957edbb5744ae194409fd66b6c 100644
--- a/community/asuran-cli/APKBUILD
+++ b/community/asuran-cli/APKBUILD
@@ -2,11 +2,12 @@
 # Maintainer: Duncan Bellamy <dunk@denkimushi.com>
 pkgname=asuran-cli
 pkgver=0.1.6
-pkgrel=5
+pkgrel=6
 pkgdesc="Asuran is a new archive format and rust implementation"
 url="https://gitlab.com/asuran-rs/asuran"
 arch="all !s390x !riscv64"
 license="BSD-2-Clause-Patent"
+options="net"
 makedepends="
 	cargo
 	cargo-auditable
@@ -19,6 +20,7 @@ source="https://gitlab.com/asuran-rs/asuran/-/archive/v$pkgver/asuran-v$pkgver.t
 	openssl3.patch
 	new-rust.patch
 	system-zstd.patch
+	libc.patch
 	"
 builddir="$srcdir/asuran-v$pkgver"
 
@@ -53,4 +55,5 @@ sha512sums="
 d2a9d1415bf7caf95448d3068298d162359c76b27faf5ea2c62c7da9854f536bdcc7f0a3eabe95474a5f11926109978ba47a2b1aaf2dfa5d8d529c8e535457e0  openssl3.patch
 4b60c0928c7485436031cf933888cf2dfc9ce7c7f13b93b0845d2b6867a5be49a3ae18892c89c2e84a346c6c351e659c678dfda6683ea4547c738d30da669e3d  new-rust.patch
 7eef6f1a720c86705ee2fc0606ead13a1b7619ac0550a2783d1a480ab3c84c6d194ba9b51907f3ab203f43f34c2a8382d2d5067ec0da8ee7671ac75aac34cab1  system-zstd.patch
+c512916af415c89f9fa7f1d971eee199679e2258af630e75398575c4a2e23002a7c3b3867f1f15470c36453396fdc3952adfcae0ce3f6c1de99586be0354eb4e  libc.patch
 "
diff --git a/community/asuran-cli/libc.patch b/community/asuran-cli/libc.patch
new file mode 100644
index 0000000000000000000000000000000000000000..87d767949c40e93f5965429533fcae9dac575d80
--- /dev/null
+++ b/community/asuran-cli/libc.patch
@@ -0,0 +1,15 @@
+diff -Nurp a/Cargo.lock b/Cargo.lock
+--- a/Cargo.lock	2023-11-14 16:34:23.800972275 +0000
++++ b/Cargo.lock	2023-11-14 16:34:41.085194033 +0000
+@@ -909,9 +909,9 @@ checksum = "e2abad23fbc42b3700f2f279844d
+ 
+ [[package]]
+ name = "libc"
+-version = "0.2.71"
++version = "0.2.150"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "9457b06509d27052635f90d6466700c65095fdf75409b3fbdd903e988b886f49"
++checksum = "89d92a4743f9a61002fae18374ed11e7973f530cb3a3255fb354818118b2203c"
+ 
+ [[package]]
+ name = "libssh2-sys"