diff --git a/community/melonds/APKBUILD b/community/melonds/APKBUILD
index bfb7b051eb619371004bdde9da5e0bf6fdfdc140..e7ea9dfa4a8dfb5d61d296efabe9b94ed039590a 100644
--- a/community/melonds/APKBUILD
+++ b/community/melonds/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
 pkgname=melonds
 pkgver=0.9.5
-pkgrel=2
+pkgrel=3
 pkgdesc="Nintendo DS Emulator"
 url="https://melonds.kuribo64.net/"
 arch="all"
@@ -21,6 +21,7 @@ makedepends="
 source="$pkgname-$pkgver.tar.gz::https://github.com/Arisotura/melonDS/archive/$pkgver.tar.gz
 	0000-remove-failing-assertion-x86.patch
 	gcc12.patch
+	gcc14.patch
 	"
 options="!check" # No test suite
 builddir="$srcdir/melonDS-$pkgver"
@@ -45,4 +46,5 @@ sha512sums="
 115cf04e4e22a20016ac4f2946aef917e5c9566b1a5f18599f7b7c47b0ac71e3645157a8a21622ab83683848c57ab25e6d6fcff0df559087b56642d99ffe40ec  melonds-0.9.5.tar.gz
 d5cabf1dfc3932bae2b939b4f87efd1caf14499d98f324f9013bd3e7ff33656e676c32d92ed912137a68f5e48163082472d722113d2957080174b187be52940f  0000-remove-failing-assertion-x86.patch
 d85d6e2f8f4651d04db7f456a9951f712c8f66492b1938f00483b924c2371bf5794ee1071d687cc932fd0190d2a877fc009a7fc477c3cb5728983dff09413e3b  gcc12.patch
+384aebf6a5d9fd389edefe9a60b921ad3d1596bad5ee50bded537dc8856da7bdbba5ea9410a1fe9e6abbb866871aec541d0890f0397ef6c6abfb126386b94354  gcc14.patch
 "
diff --git a/community/melonds/gcc14.patch b/community/melonds/gcc14.patch
new file mode 100644
index 0000000000000000000000000000000000000000..15d08ffdea988140d103017c2abf7eee8b34c479
--- /dev/null
+++ b/community/melonds/gcc14.patch
@@ -0,0 +1,12 @@
+Source: https://github.com/melonDS-emu/melonDS/pull/1874
+
+--- melonDS-0.9.5-origin/src/DSi_Camera.cpp
++++ melonDS-0.9.5/src/DSi_Camera.cpp
+@@ -16,6 +16,7 @@
+     with melonDS. If not, see http://www.gnu.org/licenses/.
+ */
+ 
++#include <algorithm>
+ #include <stdio.h>
+ #include <string.h>
+ #include "DSi.h"