diff --git a/community/directfb/APKBUILD b/community/directfb/APKBUILD
index d5a69a27081f4ff632bdf557866446eccd5e25ff..9bc51c1e364f739a139def8e2a57f1d19970786b 100644
--- a/community/directfb/APKBUILD
+++ b/community/directfb/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Clayton Craft <clayton@craftyguy.net>
 pkgname=directfb
 pkgver=1.7.7
-pkgrel=7
+pkgrel=8
 pkgdesc="Library for hw graphics acceleration, input dev, windowing system on top of the Linux fb device"
 arch="all"
 url="https://github.com/deniskropp/DirectFB"
@@ -20,6 +20,7 @@ source="
 	0006-fix-client-gfx_state-initialisation.patch
 	0007-tslib-Automatically-detect-touchscreens-using-ts_setup.patch
 	0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch
+	fix-missing-basename.patch
 	"
 
 prepare() {
@@ -65,4 +66,5 @@ c768ca7a4dae7fc0cd7d4fa559ab74adb6b5f21245e0f9b5d56af15b20effc04e6739e86d52d65c9
 6b118928c2ebe58654e1bf32433b084f4dc150526eec1b53f9eb4b856aee25733bd8d6114fde973fcb64416e4146f458cdb75e5836d7507cf802b84e44544462  0006-fix-client-gfx_state-initialisation.patch
 43000c629eb24bd6b88d284dc010ea5a2a3facbf9498ab752127c25a890fd52b9a29a09d46264befea9fef19dcfe6f24d6cefa103a68d4c2ab185b6142a5c1b9  0007-tslib-Automatically-detect-touchscreens-using-ts_setup.patch
 a21470281e7886ee37b0c1e49498e250a890894cee8ab6c5d46f563cd75c132d112d993e047ca0649b7cd545f07b5a6476e7027e56bcc9bd2350d282f01f71b3  0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch
+210b29a79b12302071e15b6554b4c117efc4329d17ed82319c22c0f6c0f95395ec246de6e6f2878ae6e3a82d807cf5ce118660d1f19bc8e8619d7e192fca0cb3  fix-missing-basename.patch
 "
diff --git a/community/directfb/fix-missing-basename.patch b/community/directfb/fix-missing-basename.patch
new file mode 100644
index 0000000000000000000000000000000000000000..204f6c0ca75d16aeb0baf9c873bbf06004b7507d
--- /dev/null
+++ b/community/directfb/fix-missing-basename.patch
@@ -0,0 +1,13 @@
+diff --git a/systems/fbdev/fbdev.c b/systems/fbdev/fbdev.c
+index 2e2ddf9..9038f5b 100644
+--- a/systems/fbdev/fbdev.c
++++ b/systems/fbdev/fbdev.c
+@@ -97,6 +97,8 @@
+ #include "agp.h"
+ 
+ #include <core/core_system.h>
++/* include basename */
++#include <libgen.h>
+ 
+ DFB_CORE_SYSTEM( fbdev )
+