Commit bc041ed5 authored by Leo's avatar Leo Committed by Natanael Copa

community/bam: enable check and modernize

- Fix license
- Use modern style
- Fix compilation of tests against lua5.3
parent 07afa390
......@@ -2,25 +2,29 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
pkgname=bam
pkgver=0.5.1
pkgrel=1
pkgrel=2
pkgdesc="Fast and flexible build system using Lua"
arch="all !s390x" #luajit unavail on excluded arches
url="https://github.com/matricks/bam"
makedepends="lua5.3-dev luajit-dev"
license='ZLIB'
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/matricks/bam/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
makedepends="lua5.3-dev"
checkdepends="python"
license='Zlib'
source="$pkgname-$pkgver.tar.gz::https://github.com/matricks/bam/archive/v$pkgver.tar.gz
use-lua5.3.patch
"
build() {
cd "$builddir"
sh make_unix.sh
}
check() {
make test
}
package() {
cd "$builddir"
install -Dm755 bam "$pkgdir"/usr/bin/bam
install -Dm755 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
sha512sums="e6f1b3daad6073c58b0e3cbf836bb0a6b66f0c36532d6e6eca9949239ab8b584cc88f892cce6f74974e370a8a688f33a95dde86dd65cc1790e49e5f8aeab0fef bam-0.5.1.tar.gz"
sha512sums="e6f1b3daad6073c58b0e3cbf836bb0a6b66f0c36532d6e6eca9949239ab8b584cc88f892cce6f74974e370a8a688f33a95dde86dd65cc1790e49e5f8aeab0fef bam-0.5.1.tar.gz
7ad509adb06c896bc66f16e548d4ec8ef44a6c98571ae0a6e92b964717ff7f4981852792cb5bb83cb23ad4902e95aadf505c9f48ab9803b2359783a27be57c3b use-lua5.3.patch"
diff --git a/Makefile b/Makefile
index d804874..c661181 100644
--- a/Makefile
+++ b/Makefile
@@ -9,9 +9,9 @@ PYTHON ?= python
# flags
-LUA_LIBS := $(shell $(PKG_CONFIG) --libs lua 2>/dev/null || echo "-llua")
+LUA_LIBS := $(shell $(PKG_CONFIG) --libs lua5.3 2>/dev/null || echo "-llua")
LIBS += -lm -lpthread $(LUA_LIBS) -ldl
-LUA_CFLAGS := $(shell $(PKG_CONFIG) --cflags lua 2>/dev/null || echo "-I/usr/include/lua")
+LUA_CFLAGS := $(shell $(PKG_CONFIG) --cflags lua5.3 2>/dev/null || echo "-I/usr/include/lua")
CFLAGS += $(LUA_CFLAGS)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment