diff --git a/main/hostapd/0001-hostapd-Add-the-missing-CONFIG_SAE-option-to-the-def.patch b/main/hostapd/0001-hostapd-Add-the-missing-CONFIG_SAE-option-to-the-def.patch
new file mode 100644
index 0000000000000000000000000000000000000000..97d6e046d9e22a9b91aa7147a948025d294fd38d
--- /dev/null
+++ b/main/hostapd/0001-hostapd-Add-the-missing-CONFIG_SAE-option-to-the-def.patch
@@ -0,0 +1,30 @@
+From 6ff8bda992463a8c0dc34ee18820ca56cf9cccc0 Mon Sep 17 00:00:00 2001
+From: Yegor Yefremov <yegorslists@googlemail.com>
+Date: Wed, 30 Mar 2022 10:11:16 +0200
+Subject: [PATCH] hostapd: Add the missing CONFIG_SAE option to the defconfig
+
+CONFIG_SAE was added to wpa_supplicant's defconfig but wasn't
+added to the hostapd's defconfig file.
+
+Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
+---
+ hostapd/defconfig | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/hostapd/defconfig b/hostapd/defconfig
+index 6b50b6c59..611f96ffa 100644
+--- a/hostapd/defconfig
++++ b/hostapd/defconfig
+@@ -161,6 +161,9 @@ CONFIG_IPV6=y
+ # final IEEE 802.11ax version.
+ #CONFIG_IEEE80211AX=y
+ 
++# Simultaneous Authentication of Equals (SAE), WPA3-Personal
++#CONFIG_SAE=y
++
+ # Remove debugging code that is printing out debug messages to stdout.
+ # This can be used to reduce the size of the hostapd considerably if debugging
+ # code is not needed.
+-- 
+2.30.2
+
diff --git a/main/hostapd/APKBUILD b/main/hostapd/APKBUILD
index b31b47a6066a6f32747021dff5f24b44704fe5e5..23035e8b68d76d7e965dd225766a1c9a829bf661 100644
--- a/main/hostapd/APKBUILD
+++ b/main/hostapd/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=hostapd
 pkgver=2.10
-pkgrel=2
+pkgrel=3
 pkgdesc="daemon for wireless software access points"
 url="https://w1.fi/hostapd/"
 arch="all"
@@ -11,8 +11,10 @@ subpackages="$pkgname-doc $pkgname-openrc"
 source="https://w1.fi/releases/hostapd-$pkgver.tar.gz
 	$pkgname.initd
 	$pkgname.confd
+	0001-hostapd-Add-the-missing-CONFIG_SAE-option-to-the-def.patch
 	"
 options="!check" #no testsuite
+patch_args="-p2"
 builddir="$srcdir"/$pkgname-$pkgver/hostapd
 
 # secfixes:
@@ -40,6 +42,8 @@ builddir="$srcdir"/$pkgname-$pkgver/hostapd
 #     - CVE-2017-13088
 
 prepare() {
+	default_prepare
+
 	cd "$builddir"
 	sed -i -e "s:/etc/hostapd:/etc/hostapd/hostapd:g" \
 		hostapd.conf
@@ -58,6 +62,7 @@ prepare() {
 		-e '/^#CONFIG_LIBNL32=y/s/^#//' \
 		-e '/^#CONFIG_ACS=y/s/^#//' \
 		-e '/^#CONFIG_WEP=y/s/^#//' \
+		-e '/^#CONFIG_SAE=y/s/^#//' \
 		defconfig >> .config
 	echo "CC ?= ${CC:-gcc}" >> .config
 	echo "CFLAGS += -I/usr/include/libnl3" >> .config
@@ -95,4 +100,5 @@ sha512sums="
 243baa82d621f859d2507d8d5beb0ebda15a75548a62451dc9bca42717dcc8607adac49b354919a41d8257d16d07ac7268203a79750db0cfb34b51f80ff1ce8f  hostapd-2.10.tar.gz
 b54b7c6aa17e5cb86a9b354a516eb2dbefb544df18471339c61d82776de447011a2ac290bea1e6c8beae4b6cebefafb8174683ea42fb773e9e8fe6c679f33ba3  hostapd.initd
 0882263bbd7c0b05bf51f51d66e11a23a0b8ca7da2a3b8a30166d2c5f044c0c134e6bccb1d02c9e81819ca8fb0c0fb55c7121a08fe7233ccaa73ff8ab9a238fe  hostapd.confd
+7cde99c431f1cf746473ae53c3009735c2a718e7038c3bc1629fc45ca85a191d799e975960da96e3cf14a56389ba06eee78453a9dd457941d6af758b730cbd05  0001-hostapd-Add-the-missing-CONFIG_SAE-option-to-the-def.patch
 "