diff --git a/community/hugo/APKBUILD b/community/hugo/APKBUILD
index 84bcdd6fc97ae9522f3671552f6247741f4ec206..74c0a016fbcfb7802274630ec6dc460938915187 100644
--- a/community/hugo/APKBUILD
+++ b/community/hugo/APKBUILD
@@ -2,13 +2,14 @@
 # Contributor: Michał Polański <michal@polanski.me>
 # Maintainer: Thomas Boerger <thomas@webhippie.de>
 pkgname=hugo
-pkgver=0.90.1
+pkgver=0.91.2
 pkgrel=0
 pkgdesc="Fast and flexible static site generator written in Go"
 url="https://gohugo.io/"
-arch="all"
 license="Apache-2.0"
+arch="all"
 makedepends="go"
+checkdepends="py3-docutils"
 subpackages="$pkgname-doc $pkgname-bash-completion"
 source="https://github.com/gohugoio/hugo/archive/v$pkgver/hugo-$pkgver.tar.gz
 	skip-git-tests.patch
@@ -18,9 +19,10 @@ source="https://github.com/gohugoio/hugo/archive/v$pkgver/hugo-$pkgver.tar.gz
 	skip-image-test.patch
 	"
 
-# npm is not available on mips64
-if [ "$CARCH" != "mips64" ]; then
-	checkdepends="npm"
+
+# npm is not available on riscv64
+if [ "$CARCH" != "riscv64" ]; then
+	checkdepends="$checkdepends npm"
 fi
 
 build() {
@@ -41,10 +43,10 @@ package() {
 }
 
 sha512sums="
-78f0054fda8b103f8be83ca5abed5137038cfafadf27d28c348c917d5ec011576c722428adc603c3f1d6eb83879c68093065e74ec20a981e19d7c50d6adb2177  hugo-0.90.1.tar.gz
+0994cc97c858b15991a5d7705a8f2f83154303d1daf4f3b3019e39d8789707875a0b90cd6f41e34bba42f10b9a13c13942ad06ddcd4b4808a4889b031a7b3d8e  hugo-0.91.2.tar.gz
 f07d458b5df72d0b10e0fd9ec6120502b62af1ee347f0ec83eda99147c525327c0098150db80450da48c5bc03d825279e35f0940dae5d909203757abb6bd1a20  skip-git-tests.patch
 6ba192d8cb67f115f7ce596c297a55fc64713a4cdb0077cfbb7e45051c7560f5b668da88f513d4f34d8e0eeb4a9d991c5312d62e454c85e95960d8a33f0f8f69  skip-para-test.patch
-0eada6d4f318775d24a55bec65349e62148b71322f084874a608596f8248cc948632e5f1823c3e86463090e35777e14784c2bcdb6493ad71be9b98ecc4700f24  skip-js-tests.patch
+143a337c5f7a77636774782bb3f87e6ae0db8741186bab5d6466f0e1700f7303a6a22c092852489995b1f024736627245c52a295c3f37b37135c0d05737c06be  skip-js-tests.patch
 0eafc165979d869ef401fec050678ba025431ac66b79a9761879024da8326e2dd5e9d14d90e32c3071d83dbac6973c2b4f954217e789944524b660a09131b298  increase-timeout-pagebundler-test.patch
 0feb0495f03315c9224b301ea955061fcbbf9ae8f871640fbb4b5c0792785a714f3a030f702a1f1f6a8048d60f07a133df4ced2a989df0b9c851b8503b59d26d  skip-image-test.patch
 "
diff --git a/community/hugo/skip-js-tests.patch b/community/hugo/skip-js-tests.patch
index 817328921399f5cfed1e210d2cdc7ba3d6c6c097..a654cdaf645caecbaf8fe69b4b1ea61301ba6679 100644
--- a/community/hugo/skip-js-tests.patch
+++ b/community/hugo/skip-js-tests.patch
@@ -1,4 +1,4 @@
-Reason: Skip tests that require npm on mips64
+Reason: Skip tests that require npm on riscv64
 Upstream: No
 
 diff --git a/hugolib/js_test.go b/hugolib/js_test.go
@@ -9,8 +9,8 @@ index cd0883fd..aeb784fe 100644
  )
  
  func TestJSBuildWithNPM(t *testing.T) {
-+	if runtime.GOARCH == "mips64" {
-+		t.Skip("npm is not available on mips64")
++	if runtime.GOARCH == "riscv64" {
++		t.Skip("npm is not available on riscv64")
 +	}
 +
  	if !htesting.IsCI() {
@@ -20,8 +20,8 @@ index cd0883fd..aeb784fe 100644
  }
  
  func TestJSBuild(t *testing.T) {
-+	if runtime.GOARCH == "mips64" {
-+		t.Skip("npm is not available on mips64")
++	if runtime.GOARCH == "riscv64" {
++		t.Skip("npm is not available on riscv64")
 +	}
 +
  	if !htesting.IsCI() {
@@ -43,8 +43,8 @@ index 61b2ef6d..d2bb3293 100644
  )
  
  func TestResourceChainBabel(t *testing.T) {
-+	if runtime.GOARCH == "mips64" {
-+		t.Skip("npm is not available on mips64")
++	if runtime.GOARCH == "riscv64" {
++		t.Skip("npm is not available on riscv64")
 +	}
 +
  	if !htesting.IsCI() {
@@ -66,8 +66,8 @@ index 9ea1d852..4063a81a 100644
  }
  
  func TestResourceChainPostCSS(t *testing.T) {
-+	if runtime.GOARCH == "mips64" {
-+		t.Skip("npm is not available on mips64")
++	if runtime.GOARCH == "riscv64" {
++		t.Skip("npm is not available on riscv64")
 +	}
 +
  	if !htesting.IsCI() {