From b644d14d96a7d24cfd8525056fa3e1b058bab9ed Mon Sep 17 00:00:00 2001
From: Antoni Aloy Torrens <aaloytorrens@gmail.com>
Date: Fri, 12 Feb 2021 02:35:27 +0100
Subject: [PATCH] testing/lxqt-config: new aport

---
 testing/lxqt-config/APKBUILD | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 testing/lxqt-config/APKBUILD

diff --git a/testing/lxqt-config/APKBUILD b/testing/lxqt-config/APKBUILD
new file mode 100644
index 000000000000..621b8d00c375
--- /dev/null
+++ b/testing/lxqt-config/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=lxqt-config
+pkgver=0.16.0
+pkgrel=0
+pkgdesc="Tools to configure LXQt and the underlying operating system"
+url="https://github.com/lxqt/lxqt-config"
+arch="all !armhf" # armhf blocked by libkscreen, liblxqt and kwindowsystem
+license="LGPL-2.0-or-later"
+makedepends="
+	cmake libxcursor-dev lxqt-build-tools qt5-qtbase-dev
+	qt5-qttools-dev qt5-qtx11extras-dev xf86-input-libinput-dev
+	libxi-dev libudev-zero-dev libqtxdg-dev liblxqt-dev
+	libkscreen-dev kwindowsystem-dev
+	"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check" # No testsuite
+source="https://github.com/lxqt/lxqt-config/releases/download/$pkgver/lxqt-config-$pkgver.tar.xz"
+
+build() {
+	if [ "$CBUILD" != "$CHOST" ]; then
+		CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+	fi
+	cmake -B build \
+		-DCMAKE_BUILD_TYPE=None \
+		-DCMAKE_INSTALL_PREFIX=/usr \
+		-DCMAKE_INSTALL_LIBDIR=lib \
+		-DBUILD_SHARED_LIBS=True \
+		$CMAKE_CROSSOPTS .
+	cmake --build build
+}
+
+package() {
+	DESTDIR="$pkgdir" cmake --build build --target install
+}
+sha512sums="fe1ffb1ebcd5429da2d9aecfcac8d740a24175e20ba1a654304fdfa37145496d1b215c3295575fedbfc57576f57bf9176b362a75bc6365f00c03fb3599632a95  lxqt-config-0.16.0.tar.xz"
-- 
GitLab