diff --git a/testing/spiped/APKBUILD b/testing/spiped/APKBUILD
index 6f581588dc435a807d8d42c515d07a80fc32a454..b3d49d4a2fec1a58982aa3e4b20dced93ec81c54 100644
--- a/testing/spiped/APKBUILD
+++ b/testing/spiped/APKBUILD
@@ -10,8 +10,22 @@ license="BSD-2-Clause"
 makedepends="openssl-dev"
 source="https://www.tarsnap.com/spiped/spiped-$pkgver.tgz"
 
+build() {
+	make
+}
+
 check() {
-	make test
+	# choose a shorter path to workaround the
+	# 107 char limit for unix domain sockets.
+	local testdir="$tmpdir/t"
+
+	# clear testdir to allow re-running of check().
+	rm -rf "$testdir"
+	mkdir -p "$testdir"
+
+	# symlinking prevents rebuild of spiped.
+	ln -s "$builddir"/* "$testdir"/
+	make -C "$testdir" test
 }
 
 package() {