diff --git a/main/apcupsd/APKBUILD b/main/apcupsd/APKBUILD
index f79bd1493dcaa97924bf79f64a8c1be445f39a3e..8f906de7abfe621501c0d5edadfd9eef89a8541e 100644
--- a/main/apcupsd/APKBUILD
+++ b/main/apcupsd/APKBUILD
@@ -8,12 +8,19 @@ url="http://www.apcupsd.org"
 arch="all"
 license="GPL-2.0-or-later"
 depends="util-linux"
-makedepends="net-snmp-dev linux-headers gd-dev libusb-compat-dev"
+makedepends="
+	gd-dev
+	libusb-compat-dev
+	linux-headers
+	mandoc
+	net-snmp-dev
+	"
 options="!check" # no test suite included
 source="https://sourceforge.net/projects/apcupsd/files/apcupsd%20-%20Stable/$pkgver/apcupsd-$pkgver.tar.gz
 	apcupsd.initd
 	apcupsd.powerfail.initd
 	apcupsd-alpine.patch
+	manify-with-mandoc.patch
 	"
 
 prepare() {
@@ -50,7 +57,10 @@ webif() {
 	mv "$pkgdir"/etc/apcupsd/*.cgi "$subpkgdir"/usr/share/webapps/apcupsd
 }
 
-sha512sums="c953bbf3e08f809748a7978a3952604176390d1cd276f187fe096d9bc3c8993b52127e8350c0363387da41318e24b4d1e00ea58df71f3bb8f50c9a5a64cd2d7f  apcupsd-3.14.14.tar.gz
+sha512sums="
+c953bbf3e08f809748a7978a3952604176390d1cd276f187fe096d9bc3c8993b52127e8350c0363387da41318e24b4d1e00ea58df71f3bb8f50c9a5a64cd2d7f  apcupsd-3.14.14.tar.gz
 82bff9001e86e2eb082e0bdebce69563458bb9e864f6f70622aa7d173d5134522f295b7f2496a9ef74aa6075e52026f714810c49a866026ee834acb8adbb3c70  apcupsd.initd
 8d1c266bd86cd1cdf4fccdd171a877957bf5e26e1bb8c20e4c9c6b362a63d8cc1b887a1661939e4e56228a8d23dfc81fe782806b5d1527423c2ef7872cbeb881  apcupsd.powerfail.initd
-4f0712519213c4ef14f41eeef681c5498fac7bf42f205de8a855938f8e834d9488d86820d7c883e89d0d305ee287e17e2d321dbbc98ae12f8487bf58aa0d4a6b  apcupsd-alpine.patch"
+4f0712519213c4ef14f41eeef681c5498fac7bf42f205de8a855938f8e834d9488d86820d7c883e89d0d305ee287e17e2d321dbbc98ae12f8487bf58aa0d4a6b  apcupsd-alpine.patch
+151d6c2f2a150a9ffbf411042e8f5df883c79b2ac15292e009edc58338d790917b1afd01dc588c08741be70cc6de6bb1b13b4ddd233e5907efaebb7c5c33e311  manify-with-mandoc.patch
+"
diff --git a/main/apcupsd/manify-with-mandoc.patch b/main/apcupsd/manify-with-mandoc.patch
new file mode 100644
index 0000000000000000000000000000000000000000..cb1aa8bb281f19757cd2f3c7ff078b7fc32ef212
--- /dev/null
+++ b/main/apcupsd/manify-with-mandoc.patch
@@ -0,0 +1,15 @@
+cmd:col is no longer provided by util-linux-misc
+since 2.40, it was disabled for musl libc in
+https://github.com/util-linux/util-linux/commit/8886d84e25a457702b45194d69a47313f76dc6bc
+
+--- a/autoconf/targets.mak
++++ b/autoconf/targets.mak
+@@ -298,7 +298,7 @@
+ # Format a manpage into plain text
+ define MANIFY
+ 	@$(ECHO) "  MAN  " $(1) -\> $(2)
+-	$(V)man ./$(1) | col -b > $(2)
++	$(V)mandoc -Tascii ./$(1) > $(2)
+ endef
+ 
+ # Rule to build a Windows resource object from the source RC file