diff --git a/community/soundtouch/APKBUILD b/community/soundtouch/APKBUILD
index 6f04fcaf3f3a7b80b5ca727d87f4b6e68a5e532f..44b404b243e6a35d19f83d367d11c5f8b52d388c 100644
--- a/community/soundtouch/APKBUILD
+++ b/community/soundtouch/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=soundtouch
 pkgver=2.3.2
-pkgrel=1
+pkgrel=2
 pkgdesc="Audio Processing library for changing Tempo, Pitch and Playback Rates"
 url="http://www.surina.net/soundtouch/"
 arch="all"
@@ -10,6 +10,7 @@ makedepends="cmake samurai"
 subpackages="$pkgname-dev"
 source="https://www.surina.net/soundtouch/soundtouch-$pkgver.tar.gz
 	aarch64-neon.patch.noauto
+	no-fast.patch
 	"
 builddir="$srcdir/$pkgname"
 options="!check" # no tests
@@ -51,4 +52,5 @@ package() {
 sha512sums="
 72cd38f3e11f3c55ff7ed3691fd9a749a5f8d072e08ed03f2fd43a8664962138afaf3e4647116940e86f6ae374a1ba3bcd4b108280da29f3ffa6091cf383ea35  soundtouch-2.3.2.tar.gz
 f32042e29c74a17df745c42ad3ebaf72a8c303f63e45cc8c5d467e4598fed0a51dab37885b5850d8c7ef2df4976c475eebb18c0517eeb2776a09ebb7376f922b  aarch64-neon.patch.noauto
+4c46d42f07d4de27de7492e0f53c984949ce1724257e54947d85258bad7dd2373546b47590212a28a7c4d702acff83bed7e20dc2242f55f036296ce4e9b1d421  no-fast.patch
 "
diff --git a/community/soundtouch/no-fast.patch b/community/soundtouch/no-fast.patch
new file mode 100644
index 0000000000000000000000000000000000000000..75602d3c9716eee2424236f885aed36727215405
--- /dev/null
+++ b/community/soundtouch/no-fast.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 14f23e8..993f0e1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,7 +7,7 @@ if(MSVC)
+   set(COMPILE_DEFINITIONS /O2 /fp:fast)
+   set(COMPILE_OPTIONS )
+ else()
+-  set(COMPILE_OPTIONS -Ofast)
++  set(COMPILE_OPTIONS -O3)
+ endif()
+ 
+ #####################